FX Channel

I’m trying to send 4 tracks to an FX track on an EDM rise and I’m having a challenging time with it. I’ve created a high pass filter FX channel with Izotope and i can route one track to it but when i go to the mixer only that track shows up with a blue dot and the rest show up with a yellow dot when i try to send it there. The only one that i hear is the one with the blue dot. Am i missing something? I’ve spent hours on this tonight and i’m not sure what’s up. Any ideas?


Create a Group Channel. Route your source tracks to the Group. Add your filter insert to the Group’s insert effects.

On the sends for channels that have a yellow dot, at the left end of the slot you will see an enable when you hold the mouse over the slot. Click the enable and the ellow dot will become blue. No need for an extra group channel.