GA4 - Installationspfad ändern/angeben?

Hi!

Habe mir soeben die GA4-Trial herruntergeladen, um voller Erwartungen den GA4 auszuprobieren. Vorher extra noch nen Dongle bestellt, um die Trial-Lizenz zu aktivieren. Kenne den GA noch von Version 1.

Nun ja, leider lässt sich das Programm nicht installieren, da ich den Installationspfad nicht ändern kann. Es wird zwangsweise in C:\Programme\Steinberg[etc] installiert. Auf C: habe ich allerdings nur noch 6GB frei, auf D: aber noch über einen TB, da soll es auch hin! Dort liegt ja auch der restliche VST- und Cubase-Kram. Ähm? Das ist das 1. Programm in meiner 20-jährigen Windows-Nutzer-Karriere, bei dem ich den Installationpfad nicht angegeben kann. Irgendwie mehr als steinzeitlich…

Was tun?
Habe ich den Dongle unnötigt besorgt?
Hatte ja bereits mit dem gedanken Gespielt GA4 zu kaufen, da ich mit GA1 sehr zufrieden war damals.

Grüße.

Das Programm gehört ja auch in den Programme-Ordner, wo auch die andren Programme wohnen. Die VSTSOUND-Dateien in den VST-Sound-Ordner. Den Pfad dorthin kannst du doch während der Installation angeben.

Den Pfad kann ich eben leider nicht angeben, das ist ja das Problem…
Mein Standard-VST-Ordner ist übrigends auch im D:-Laufwerk, dort wo genügend Platz vorhanden ist.
Konnte ich bei der Cubase-Installation alles schön angeben, aber Groove Agent schert sich nicht drum.
Und wo das Programm hingehört möchte ich gerne selber aussuchen dürfen. :slight_smile:

Starte die Installation mal nicht über das Startcenter sondern mit
GrooveAgent_64bit.msi

(gleiches Procedere wenn noch notwendig mit dem eLicencer und dem Content-setup)

Super, das war der Bringer. Wenn ich die MSI manuell starte kann ich den Installationspfad angeben.
Danke für Deine Hilfe!

Jetzt muss ich mich nur noch in die Komplexität des GA4 einarbeiten… :wink:

Hatte ich auch zunächst gedacht, dass die Installation über die msi-Dateien eine saubere Vorgabe des Installationspfades zulässt …
Pustekuchen!!
Obwohl ich den “VST Sound”-Ordner unter …Steinberg/Groove Agent installieren möchte, werden nur einige der vstsound-Dateien dort abgelegt, die anderen schiebt die Installationsroutine gnadenlos in den ursprünglich vom Programmierer dafür vorgesehenen Ordner unter Program Data.

Ich kann mich @aldipower nur anschließen: “Steinzeit” - oder Bevormundung des Users - oder aber einfach schlechte Programmierarbeit?

Liebe Leute bei Steinberg bzw. liebe kreative Zulieferer:

Bitte veröffentlich zügig ein Update mit der Behebung dieses dicken Lapsus’ (und der bereits bekannten Bugs).

Und wo Ihr gerade schon einmal dabei seid:
Die Qualität des Handbuchs ist (gerade gemessen an der m. E. hervorragenden Qualität des Programms an sich) bzgl. Infogehalt und Übersichtlichkeit unterirdisch (und das ist nicht nur meine Meinung, wie man unschwer den Posts in verschiedenen Foren entnehmen kann).

Herzliche Grüße und viel Erfolg!

Im Programdata-Ordner liegen doch nur Verknüpfungen auf den Samplecontent, die auf den von Dir gewählten Pfad verweisen?
Ich würde sagen, das entspricht der MicrosoftDesignPhilosophie.

@Voodoo:
Leider muss ich Dir widersprechen.
Zumindest unter Win 7 x86 ist der Ordner C:\User\All Users eigentlich eine Verknüpfung zum Ordner C:\ProgramData.
ProgramData selbst aber enthält “reale” Dateien, bei mir nach Installation von GA4 in GB-Größe - trotz des eigentlich anders eingestellten Pfades für VST Sound.

Da ich es ungern habe, wenn ein Programm seine Daten in tausend Ecken versteckt, lege ich (wenn wählbar) z. B. Werks-Soundbanks und Werks-Presets von Programmen auch in C:\Program Files in einem Unterordner des jeweiligen Programmordners ab.

Daher ärgert es, dass GA4 zwar (zumindest über den “msi-Trick”) eine komplett eigenständige Wahl der Installationsordner vorgaukelt, letztendlich aber nur einige der Dateien am ausgewählten Ort installiert, andere Dateien jedoch am ursprünglich von der GA-Installatonsroutine vorgeschlagenen Ort ablegt.

Edit:
Als ich dann alles deinstalliert, sämtliche Registry-Einträge zu GA4 gelöscht und anschließend den Content über die msi-Datei nochmals, dieses Mal ohne Änderung des Installationspfads, installiert hatte, musste ich feststellen, dass der Installer - warum auch immer - die vstsound-Dateien auf zwei verschiedene VST Sound Ordner innerhalb ProgramData verteilt, nämlich C:\ProgramData\SteinbergContent\Groove Agent\VST Sound (je 4 Kits und Eco-Kits) und C:\ProgramData\Steinberg\Content\VST Sound ("…Groove_Agent" und “…GA_Presets”).

Fazit:
Damit Standalone und VST in den richtigen Ordner gelangen, installiert man diesen Teil über die entsprechende msi MIT Auswahl der Ordner.
Damit alle vstsound-Dateien (weitestgehend) zusammenbleiben, installiert man den Content über die Content-msi OHNE Änderung der vorgegebenen Ordner.
Für Erste eine akzeptable Lösung, aber hier sollte Steinberg nachbessern.

Hmm, das ist bei mir anders. Ich habe dort nur Verknüpfungen zum Content liegen. Allerdings unter win8x64. Und ich habe den normalen Installer benutzt.

Da das mit den Verknüpfungen funktioniert, könnte es für dich evt. eine Lösung sein. Dann aber wohl leider eine manuelle Lösung.

Da auf meinem Band-Laptop unter Win 7 x64 der gleiche Zustand herrscht:
Vielleicht ist der Installer nur unter Win 8 entwickelt worden und man hat Win 7 schlicht vergessen …
:smiley:

Du musst bei den Content-Dateien (*.vstsound) zwischen “Sound” -> landet im umgebogenen Ordner und “Presets” unterscheiden. Diese sowie die Verknüpfungen zu den Soundfiles landen im ursprünglichen Ordner - zumindest ist das bei mir so und auch nachzuvollziehen. Manchmal sind auch die Preset-Dateien relativ groß.
Das ganze ist nicht zu verwechseln mit den *.vstpreset-Dateien.