Gap after mid-system time signature

I’ve just realised changing this setting (in Engraving Options/Spacing Gaps) has the unfortunate side effect of also changing the gap after a cautionary time signature at the end of a system. The default is 1/2 space and I want to reduce this to 0, but if I do that cautionary time signatures lose their sliver of empty stave to their right. I want to reduce this value to 0 because I don’t see why there should be any extra space after time signatures - the gap should be treated in the same way as that between a barline without a time signature and the first note or other object in a bar. Please can we make these independent settings?

This post might be helpful.

I’ve made a note of this but can’t promise when we will be able to implement it.

Many thanks Daniel.