Generalised MIDI dropouts Win 10

Over a few months now, in Cubase 8.5 and beyond I am finding that MIDI input disappears across all hardware inputs.
One moment its all fine, the next time - gone.

I confess tech comes hard here, much rather hit the keys, but I do need to narrow this down.

I simply don’t know how to do this. If it was an Asio driver I would be fine, but AFIK there are no MIDI facilities/trouble shooters in Windows.

After the input silence descends in Cubase 8.5, I can go to a vst and hit the virtual keyboard and hear the notes. The associated MIDI track shows no activity, although set up right and previously viable.

Closing down Cubase is not enough. I keep a simple piano TruePianos on the desktop and as standalone this is also silent.

A restart restored everything


Ideas people please?

If your midi hardware is connected via usb then Win10 may be turning them off according the Power \settings .
Check that the " USB selective suspend setting " is set to disabled .

Control Panel > Power Options > Change Plan Settings > Change advanced power settings
Then in the Power Options smaller window expand " Usb settings " and then " Usb selective suspend setting " . Now check that it is set to " disabled " .

hth :smiley:

Thank you, checked it was already USB selective suspend settings/ Disabled.

Today, I went through all my Universal Serial Bus (USB) controllers in Device managers. I found two that were not updated. both labelled Intel® C160 series X99 chipset USB enhanced Host Controller # n

Maybe that will do it, not sure, will have to give it a while.

BTW I am working in a version of high performance mode with no hibernations or sleeps

How many midi interfaces do you use and what kind of devices are attached to them? (Did you check your synchronisation settings and your devices in “All midi” ?) Might be something looping around or interfering when you hit a midi track. Could even be a faulty cable or a loose connector. Try fiddling around with your cable(s) to see if the connection drops or goes into error.

I have three devices, they all go down atthe same time. Therefore not a cable issue. Thank you for trying. All drivers, win 10 drivers updated too.

Z

Are the devices connected thru 3 different midi interfaces or are they connected thru a midi patchbay? Did you check your synchronisation settings and your midi devices in “All midi” ?

They are all connected independently through various ports into the back of a PC, some USB2, SOme USB3. My belief is the problem is a WIN 10 issue, all drivers updated though

Where is “ALL MIDI” ? Is it in Windows or Cubase?

Z

Devices>>Device Setup>> Midi Port Setup<< Only check devices “In All Midi” like your master keyboard and or other devices you want to use to play and record your Midi tracks. Also check your Sychronisation settings In >>Transport>>Project Synchronization Setup… Make sure your syncing to the right devices and uncheck devices that dont need sync. ( I also check Midi clock follows… Always Send… and Send Midi Clock in Stop Mode) (y)

Thank you Terry but all of that is in order
Z

Checked Preferences>>MIDI>>ASIO Latency Compensation Active by Default<< ?

Sorry but it’s not about this. Standalones also stop responding.

What do you mean with “Standalones” ?