Generic midi controller issues

Hello everyone,

I’ve been using Cubase for quite a while now, but I’ve recently started fiddling with using midi to control other things than just what notes my instruments play.

I used to do some DJing in the past so I have a Reloop Digital Jockey here. I’m trying to map different buttons, sliders and the jogwheels with mixed success.

The buttons are easiest and work as they should, with the exception of 1 thing: there is a huge delay (actual delay differs, sometimes more than a second) between me pressing play and Cubase starting to play. The weird thing is, in the transport bar I can see cubase receiving the midi signal straigh away, and also the play button on the transport bar is pressed as soon as I press it on my controller. The actual processing of the command seems to take ages however, any clues on what might cause this?

Then the jogwheel. I’m trying to use one as an actual jogwheel, to move the vertical timebar back and forth to the desired location. I’ve tried assigning it to time, time2, jogActive, jogLeft etc, but none of these work. I can however use it for ‘buttonpress’ commands like fastforward which works fine with the exception of the aforementioned delay. I couldn’t find any documentation on the actual meaning of all available parameters either, currently It’s just a guessing game. Any ideas on how I set this up properly?

I’m also trying to use the crossfader for horizontal zoom which I haven’t experimented with much yet, but the little things I tried didn’t work yet. Some advice on that respect would be helpful as well.

Attached is a screenshot of the current setup (crossfader isn’t in yet.)

This is Cubase Essential 5 on Windows7 64.

Thanks in advance,

Strophoid.
Digital Jockey 1.png

Little update: I completely overlooked the function ‘jog’. This now kinda makes the jogwheel work, but 1: the directions are reversed (clockwise makes the bar move back) and it only works when spinning very slowly. As soon as I try to give it some speed, the bar will glitch back and forth really quickly and effectively stay in the same place.

bump…
problems still persist :frowning:

I’m not sure if this is still the case, but there used to be a similar problem, which was worked around by adding the option “Not Automated” to the Flags column in the lower section.

Thanks for the reply, I will play with it some more soon.

Not much luck with this yet. The ‘not automated’ flag you suggested did help a little, but it’s still not working properly. The timebar just glitches back and forth when I rotate the jogwheel fast. If I do it slower, it’ll work (in both directions now), but the whole idea is being able to scan through the project fast so that’s kinda worthless. Also the delay on pushbuttons still persists. Any other tips would be welcome.

Reviving this old topic because I had a go at this again.
Adding the ‘not automated’ flag for the pushbuttons fixed the delay I had on them. No idea why or what the flag even means but this is all good now, can’t complain. Thanks for that Vic, I should’ve done what you said :stuck_out_tongue:

The problem now lies with any continuous controller I’m trying to use. The jogwheel I got to work more or less but it’s VERY glitchy and if I dial it too fast the directions will reverse :confused:
It also appears that jog is not exactly what I’m looking for anyway. What I want is to use my jogwheel to rapidly skip through my project without any sound playback, kind of like a replacement for using a whole bunch of markers and ‘skip to marker’ buttons. It appears the jog function will only go as fast as x1 on max speed. Shuttle also really isn’t what I’m after because it locks you into a certain playspeed which isn’t very intuitive I find. (I tried setting shuttle up but ran into the problem described below: I can’t get it to work in 2 directions.)

The second problem is that I’m trying to get horizontal zoom assigned to a fader. On the screen the zoom thingy also looks like a fader so I thought it’d be possible to just have a fader to zoom in and out just like that. However I could only find zoom under commands (I think that’s what it’s called) and this defaults the controller action to ‘push button’.
This way I can use the fader to zoom in or zoom out, but not both. IE: I can select zoom in, and then I can use the fader to zoom in regardless of which direction I move the fader. Anyone know if it’s possible to move the fader left for zooming out and right for zooming in? (It’s a crossfader :wink: )