Generic Remote doesnt remember settings

Hi,

I know that earlier here people have suggested importing settings from the exported file and I have done that. The problem is that next time a open a project all the assignments in the generic remote are gone and they must be imported every time again. So what gives, why doesn´t it remember the settings?

It’s export your changes after you make them. Not intuitive for sure, but true!

I first imported the file to get my tweaks, then I exported that. Now it remembers the tweaks if I close the project and open again BUT if I quit cubase and reopen a project it has lost everything. So back to square one.

Yep, that did cost me a few hours work, now I export after every little thing I tweak.

Does it work for you when you have exited cubase and come back to the project?

Yes if I remember to export, the changes are there next time I open Cubase.

The changes are there for me too but they don’t work until I press apply.

It should not require hitting Apply. Can we make sure nothing is broken here?

Could you follow this reproduction sequence exactly, starting with a new, empty project?

Add some tracks, midi and/or audio
Create a remote, add your parameters, clicking apply, etc.
Make sure you click Apply once more before you-
Export the remote xml file
Save the project, quit Cubase

Launch Cubase again and open the project

Does it work straightaway?

As you tried and other explained, the odd thing is to export your gr settings and then import same file back in, when they are already there in the first place… if it still dont work I cant help you, but I made this little video a few years back to show how to get the gr to stay. This still works for me on 9.5. https://youtu.be/bJeSZz825Ws

Here, it is not necessary to re-import the file. Just exporting saves the file, and Cubase loads it next time.

That never, ever, worked for me. The file HAS to be imported back in if I want it to stay. Cubase has worked that way since I started using GR first time in sx. Just saying.

Steve and hjwinge the instructions you both gave does not keep the settings saved. I have to open project, goto studio setup, generic remote and then click somewhere to get the apply button working, hit apply and only then the assignments work… otherwise as soon as cubase is closed and opened again it loses everything.

I think there’s a slight difference in what we’re describing.

I’m talking about only saving the GR in one project. If you don’t export, the changes you made will be lost. If you do export, they are saved, i.e, still there when re-open the project.

In any case this is a really weird process to go through- it’s a perfectly illogical method!

I tried both of yours procedure. Sure in the GR the assignments were there but they didn’t do anything until I hit apply. So every time I start working with a project afresh I need to hit apply in order to get things going. Not a major pain at all but irritating little extra job.

Hm… that is definitely not what I’m seeing here. It sounds like the remote is not connecting to the assigned input till you hit apply, nad here, it is connected from the get-go.

What is the midi port and the actual device you’re using? Or does it happen with all or any device or midi port you connect to?

I´m using CC121 and midi IN and out is cc121 in the gr.

Normally one would not use that device as a GR, since it has its own integration built-in to Cubase. Do you also have the CC121 selected as a device in Studio Setup, as in this illustration?

Yes I also have that selected in the studio setup. I had this same problem when I didn’t use the cc121 too. All the assignments work nicely. Only that it doesn’t remember them after quitting.
The four function buttons in cc121 just cry, put us to use as remote controls.

Probably would have made sense to mention that previously. It doesn’t work like that. You can use one or the other, If you’re using the Steinberg extension for the CC121, it’s not surprising that you need to hit a ply./

The problem is not that the settings are not remembered, but that the remote is not connected until you click apply. You’ll have to live with it.

Ok. Didn’t know that. But thanks anyway. It didn’t work with my keyboard controller either so go figure.