Generic Remote Issues


I’ve been going over this issue for the past 2 days and after dozens of hours I finally decided to come ask for help in the forum.
I’ve checked numerous posts and similar issues but NONE worked for me and I’m starting to lose my mind over something that should be easy to set up.

I recently got a new controller, Behringer X-Touch Compact which I would like to use to control CC’s and use the other buttons as macros (Play, Stop, Record, Add track, etc). Since I don’t want to use the faders to control volumes the Mackie setup is out of the window. So the only option is the Generic Remote setup.
This is what I get:

And it works, partially.
Faders 1 and 2 control Modulation and Breath respectively which is what I want but here’s the issue. Every other button from the X-Touch triggers the VST which is currently loaded. If I have a string library loaded and I press any button from the X-Touch it plays a note.
I found online that this issue is easily solved by going into Midi Port Setup and disabling/uncheck “IN ALL MIDI” option for the interface.
And again, it works, partially. When I do this all the buttons work without triggering the VST sound but the faders stop working.

I’ve been messing around with X-Touch editor and everything seems to be correctly set up. Can’t really understand why it is so hard to set up things that should be straight forward. Buttons seem to be easy to set up in Generic Remote setup but faders seem to be impossible to assign to CC’s.

Any help would be appreciated.
I’m sorry if the post seems a bit cluttered and the info is not easy to understand. I tried to explain it the best I could.


The problem is, you want to use the one device for 2 totally different tasks. You want to use the faders to send common MIDI CCs. These are data, which must go to the track. But you block these data, if you disable the “All MIDI Inputs”. If you disable this and you want to route the data to the track, you would need to select this specific MIDI Port as an Input of the MIDI Track.

At the other hand, you want to use the same MIDI Device to control some internal Cubase functions. So these data must not go to the track. For these data is correct, that you disabled the “All MIDI Inputs” (because these data suppose to not be routed to the track with other MIDI data).

So that’s the conflict you have. The solution would be, if Behringer X-Touch Compact could send the fader data over other MIDI Port. But I doubt it’s possible.

So the other option would be to use the Input Transformer and filter the data from the Behringer somehow out. You can’t use:

Type is | Equal | Note
Function: Filter

Then you would filter out all incoming MIDI Notes from all MIDI Devices. So you have to somehow distinguish on the hardware side, which MIDI Notes you want to pass over to the MIDI Track and which do you want to filter out. I would go thru different MIDI Channel. So again, if you could change the outgoing data from Behringer to send the data at Channel 2, then I would recommend to set it up so. Then you could use the Input Transformer this way:

Type is | Equal | Note | And
Channel | Equal | 2
Function: Filter

If Behringer doesn’t allow this, set your MIDI Keyboard (or other MIDI Device/s) to the MIDI Channel 2 and set the filter in the Input Transformer to Channel 1.

I hope this will work for you.

Thanks a lot for the detailed explanation , Martin!
I’ll try this asap and let you know if it worked out!

I don’t own an X-touch Compact, but doesn’t it have two “Layers” for this function?

One “layer” to control the DAW, and another “layer” to control VSTi?

Just wanted to log in and thank you. Changing the keyboard to Midi channel 2 and using those Transform settings seem to have worked. No more sound when pressing buttons and the faders seem to be working well.
Thank you so much!

Unfortunately Layer A and B do pretty much the same for me.
Martin’s solution worked though so all is fine! :slight_smile:

Ah! Good to know. Glad you got it working properly!