Generic Remote - losing assignments

I am working on a custom midi template for my iPad which would allow me to select all any of my MIDI tracks (over 200) plus instruments articulations. Lots of work, realy. Now I am half way through but it seems that there is a HUGE bug in Generic Remote. Everythng works fine until I close Nuendo. When I open it again half of the assignments in the lower sections are gone! The entries are there but no assignments whatsoever. I reassigned it again - worked great. Then I closed Nuendo and the same thing happened. I tried to import the saved file - it doesn’t change anything.

Any idea what is happening there? I am really very disappointed because this custom template would make my workflow much smoother.

I attach the xml file - perphaps someone with more coding experience can help.

Thanks a lot,

I have not DL’d your attachment…

But, do any of your controller names have the same name?

nuendo will let you give multiple midi controls the same name. and it will let you work with them. But when nuendo looks for the generic midi xml that you saved, it gets confused by the identical names and does not load the commands.

I ran in to this the other day, just a thought.

Thanks a lot for your answer. I think that you are right - first I was assigning unique names but after 120 tracks I got lazy and named the tracks in groups. I will check it today in the evening.

Now it works. So the names of the controllers MUST be unique. Thanks a lot once more,