Generic Remote not responding to Note On messages? [Solved]

Hi,

Cubase is suddenly not responding to Note On messages in my Generic Remote. I’ve not reset Preferences, so, if you think that’s what’s needed, I’ll try that.

In the Generic Remote editor, with Learn enabled, Cubase is seeing the Note On messages, they are learned and stored. But Cubase is not executing the Command (or any other assigned function). I’ve checked everything I can think of. Any ideas?

This can’t be a version 10 bug.

Here’s my basic Set-up:

Akai Advance 49
MIDI Port 01 - USB to PC (Midi Port OK)
MIDI Port 02 - 5 Pin MIDI DIN Cable (Keyboard Midi Out to Scarlet Interface MIDI In. This works fine for sending MIDI, so the problem is not the cable or the i/o ports.

In Studio Setup, Cubase sees all the existing MIDI I/Os. They all work. I just can’t make Generic Remote respond to Note On messages to execute assigned Command/functions. I tried Note Off and Aftertouch and those do not work.


Thanks for any suggestions on this. All I know is it was working and now is not working and I can’t solve it. :frowning:

Reimport a backup of the xml file? Sounds like something got screwed up in it.

I solved it. I did look at a backup file, but for some still unknown reason that didn’t work.

It seems Cubase wants to see the Note On message (first in), rather than the Note Off message (last in). However, when in Learn mode, the value learned is the last in, Note Off Message, but Cubase didn’t respond to those. It did respond to the Note On messages. I changed all the Note Offs to Note Ons and it all worked. I now have all 32 pads (4 banks of eight pads) all working very well again. :slight_smile:

I can’t say my analysis of this is correct, and I don’t know what went wrong to start with. When I changed the Learned Note Off Messages to Note On, it all worked.

Thanks, Steve

That’s good! :astonished: I still am wondering- what’s filtering the the note offs?

Good question. I’m not sure my 'first in/last in" theory is correct, but it is what worked.

My old G.R. xml files also had values set to Note On. So, I must have been down this road in the past, solved it, put it to bed and forgot about it.

Since I’m slowly working to bring Metagrid into my system, I wanted to re-do my current Generic Remotes. So, again, I think I may have run into a problem I’d solved earlier. But, this time around, the solution eluded me.

My observation is this:

When setting values in Learn mode in Generic Remote using MIDI Notes generated from a controller that sends Note On/Note Off message in the usual pair, Cubase seems to “learn” the Note Off messages, but, for Commands and other Functions to work, the values must be set to Note On. So, the sequence is: 1) Note On, 2) Command or Function executed, 3) Note Off, ignored. But, the GR “learns” Note Off. If you lock in the Note Off messages, then the commands and functions do not work.

It would be good to have this confirmed by the programming experts, or other expert users. If this is not some peculiarity in my local set-up, then the operations manual should include a note about it.

Per usual, the edited Generic Remote must be – exported, imported, applied, OKed – for it to function correctly. The good thing is, it works! :slight_smile:

All in all Cubase is working very well – known issues notwithstanding.

Note Off :slight_smile:

You just have to hold the piano key down while you unclick the learn button to set the slot to Note-on. This, btw, allows one to have momentary switches, e.g., snap off or snap on toggle, via note-ons and -offs in different slots. (same note for both, of course)

Interesting observation. Will keep an eye on it.

Thanks. I’ll look at that, good idea.