German keyboard very unstable


I am using a german keyboard. Since some of the shortcuts are missing on the german layout, I did assign the missing shortcuts which is no problem at all.

However, I do have the problem, that the keyboard handling of dorico seems to be very unstable. Especially after playback or setup and switching back to the write mode, suddenly the keyboard is handled as an english keyboard. That means: all the shortcuts do not work anymore, and when I try to assign them again, I get other symbols than the ones I am pressing on the keyboard. On top of that, the Ctrl-Keys do not work anymore.

So I reassigned my keyboard, but it keeps switching back and forth once in a while.

I never experienced something like this on any program I used.
Unfortunately, this is killing the work flow…

Please look into the matter.


Thanks for your post, Torsten. I think the problem you describe with the shortcuts not working any more is actually that the keyboard focus gets lost in the panels around the edge of the window, so the shortcuts don’t work again until the focus is returned to the score view. Next time this happens, try hitting Alt+0 or explicitly clicking on something in the score, and you should find that the shortcuts start working again.

It’s a bug that the keyboard focus can often get lost in the panels, not specific to the German version or using a German keyboard, and it will be fixed in the forthcoming 1.0.30 update.

I don’t know how this is on Mac or on Win in other areas, but the default installation of Windows will, here in Scandinavia, install the native keyboard layout (matching the physical keyboard) AND an English keyboard layout (not matching the physical keyboard). These can be switched between using alt-shift. I’m using the english layout as my default, just memorizing what to press for the Keyboard Commands, but it’s very easy to inadvertently change the layout …

I suspect this is likely to be the case. You can change the hotkey to switch language layouts. Open:
Control Panel\All Control Panel Items\Language\Advanced settings and then “Change Language Bar Hot Keys”. If you disable the default alt+shift then this hopefully will stop the layout changing.

Thank you very much!

Disabling Ctrl+Alt in Windows did the trick,
this tip was very helpful!