German version: Key commands

SOLVED – see post below

=====================

This is a minor thing, but I wanted to bring it to the attention of whoever is concerned:

In the localized German version the key command for inputting rests is a semi-colon (;), the yellow flag however shows a comma (,). Which btw would be more convenient, as the semi-colon requires an additional shift-key…

Also, not sure if it has to do with the localization, when I activate slur (s) by mistake, clicking it or typing s again doesn’t deactivate it. Is there some logic behind it that I haven’t grasped so far or can it be regarded as a small bug?

EDIT 2/6/18: Okay, Shift-s fixes it.
I still don’t understand why I need a different shortcut to deactivate/stop slurs. The only reason could be to stack slurs, but for what reason would one want to do this?

Eddo,
for me (Win 10) rest input has got the key command (,). Did you change something here?

(s) starts a slur and (shift + s) stops a slur. This is the case, because you can have multiple slurs nested (“verschachtelt”) - if you want.
e.g.:
press (s) to start Slur 1
(s) to start Slur 2
(Shift + s) to stop Slur 2
(Shift + s) to stop Slur 1
or any other combination …

ad 1) No, I didn’t. I’m on Mac.

ad 2) Yes, I found out (rtfm…). Just wondering why would one want to nest slurs?

Anyway, thank you for replying!

  1. Examples attached, both from Chopin Etudes.

    chopin op10 no4.PNG

@ Leo: Convinced! :wink:

Concerning (,) and (;):
I found out that the strange shortcut behavior has something to do with my home-made Mac keyboard mapping done years ago in a handy tool called Ukelele.
Setting back to default German fixes it. I didn’t change the comma and semi-colon, though, so it’s still unclear to me why Dorico doesn’t see a comma when I type one, and sees a comma when I type a semi-colon. When I use the keyboard for any other task, both commas and semi-colons behave normally…
Anyway, it’s something outside of Dorico that somehow interferes with it. I can live with it – or fix it outside of Dorico.

Solved.

I don’t have Dorico 2 yet, but I don’t suppose this has changed, so here’s a suggestion for Steinberg, regarding the nested slurs UI: show a little number on the button to indicate how many slurs are currently activated. It might feel redundant because you should know how many slurs you have activated, but sometimes you might accidentally hit the key and unknowingly add a slur level, or you get distracted during input (phone rings/child cries/your lunch boils over in the kitchen/…), so it would be helpful to see the nesting level right away without having to try and revert if it’s wrong.

In German version Dorico 2. I have my key commands from version 1.2 got imported with the update. That’s good but now I realized that 2 of my commands are still there and visible in the edit menu however they have another translation in that menu than in the key commands menu. I can’t find them there. I found others which I suppose should be the same (but in other words) however if I select them they show no command set to them.
Some other key commands are still not translated. And the command „Datei exportieren“ can be set to what I want but does nothing.

There is a bug in 2.0 that affects key commands that are “two levels deep” in the Key Commands editor, due to a problem with localisation which will be fixed in the forthcoming update. Can you be specific about the commands that appear with the wrong shortcuts?

I’m not sure this is related or not, but I too have issues with changing key commands. And I use a custom key layout made with Ukelele. In addition to not being able to make some key commands work, I can also not see the original ones in the Key Command preferences.

https://www.steinberg.net/forums/viewtopic.php?f=246&t=140045&p=753776#p753776

Paolo

I attach two screenshots which will show the problem. It is the transposing score / concert score which are wrong.

Here you can see how it is called in the Edit menu and the shortcuts set for them
Edit menu.png

I would like to have a toggling key command for this transposing and concert score. This would be very handy I have wouldn’t habe to recall both shortcuts.

2nd screenshot. I don’t know why I could not attach both at once.

This is what I found in the key commands window.
Key command.png

I believe this is the same bug discussed elsewhere on the forum for commands that are “two levels deep” in the menu of key commands: there is a localisation-related problem that prevents those mapped shortcuts from showing up in the dialog. This problem has been fixed in advance of the next release so it will not bother you further once that build is available.

You cannot set a single shortcut to toggle between concert and transposing pitch.

Something that I would encourage to check is the ability to reassign the Note Duration shortcuts. For example, on my keyboard they currently seem hard-wired to the numeric keypad (or the regular number keys).

This is a bit annoying in my case, because I will always have to press two keys for each duration. 1) By using a keyboard with no numeric keypad, I have to simulate it with the fn/ctrl+jkl… key combination. And 2) typing regular numbers requires pressing Shift before typing the actual number.

I would be happy to assign note durations to single hits (like jkl…), and make note input much more comfortable.

Paolo

ptram, can you configure your computer/laptop so you don’t need to use the SHIFT key to access the regular number keys?

If you take a look at the file keycommands_XX.json for your language in the Dorico application folder you’ll find a section with the key commands for the note durations. You could copy this section to the right place in the corresponding json file in your user data folder and replace the numbers with your own key commands. (Use a proper editor like sublime text so you’ve got some orientation with the json syntax!) I haven’t tried it myself but I think the default key commands should then be overridden by the changed ones.
I would not advise to change them right away in the first file because I seem to remember that Daniel said doing this might cause problems when you update Dorico later. And do save a backup of the file before you change anything!

@Florian, great tip! Yes, I can create my own command map myself!

@k_b, this would mean having to continually switch between keyboard layouts. Unfortunately, Apple decided to abandon the old Italian ISO layout in year 2000, and adopt a modifed US layout. This means that you have to press two keys for very common symbols, like accented characters or apostrophes. I prefer to keep the numbers in second position, and have the typing flow go without any break.

Paolo

ptram, you know that you can assign any keyboard layout to your keyboard?
I does of course not match the actual keys - but might fit your workflow in a better way…

@Florian, unfortunately it seems there is no way to add a custom map in the Preferences. However, I can use any unused layout, and rename my custom layout that way.

@k_b, yes, I know. I make use of my own custom keyboard layout on any system.

Paolo

I was thinking of adding the key commands for note durations to the json file that contains the custom key commands you defined via the preferences menu. Thus you wouldn’t need to create a new map. But I was probably not quite clear about the different files and folders involved (it’s late and English is a foreign language…). Anyway, I’m glad you got it working, this way or the other!

Florian, do you know where the custom keycommands for the Default keyboard layout are stored, on the Mac? What I can find is:

  • The .json files for each language in the Dorico > Contents > Resources folder.
  • A preferences.xml file in the ~/Library/Applications Support/Steinberg/Dorico folder, only containing general preferences.

If custom keycommands are saved elsewhere, I can’t find them.

Paolo