getting "Missing Fonts" (bug?) every time I open

It looks like the attached:


No idea why as the Project saved fine prior to the latest Dorico update (of last week) but now I get this message every time I open the Project, even after re-saving, etc. (and after I’ve tried re-setting the Music Font just to be safe).

Curious if anyone else is experiencing this?

Best -

  • D.D.

This happened to me with Figurato a few days ago, maybe reading the thread will enlighten you (as it did for me)…
https://www.steinberg.net/forums/viewtopic.php?f=246&t=168246#top

Forget the Music Font. This is text fonts. Is there an italic variant of Petaluma Script? My suspicion is that there isn’t, but you’ve set the Default Text Font to Petaluma Script (Regular). Many font styles are children of the Default Text Font - they copy the settings of the Default Text Font but with specific overrides. If some of them are overridden to be Italic (like some of the lyrics font styles, for example) then you’ll get this error if the Italic style doesn’t actually exist.

It’s not an error, it’s a warning. But yes, it’s correct that if you change the default text font to Petaluma Script, either by editing the font/paragraph styles directly or by changing the music font to Petaluma, you’ll see this warning because a number of styles (e.g. bar numbers, chorus lyrics, etc.) are set to use an italic style of whatever is the default font, and there is no italic style of Petaluma. (There’s also not likely to be an italic style for it in the future.)

There’s also little we can do about this on Windows since Windows will always report that a bold, italic and bold italic weight of a font is available, even if it’s not, because Windows is able to synthesise these faces from the regular weight (though of course they don’t look as good as ones that would be laboriously produced by a human font designer). So it’s only missing in one sense.

If it bothers you, either go through the font and paragraph styles in your document to make sure that those that use Petaluma Script don’t request an italic style, or disable the missing font warning via Preferences.

But what IS the default font when my Music Font is set to “Petaluma”? When I go to Paragraph Styles–>Default Text and change it to “Factory settings”, it defaults to “Academico”. But this has the effect of changing the text fonts with the overall Petaluma Music Font to Academico (or some other non-Petaluma font), which I don’t want. But when I subsequently switch Music Font away from and back to “Petaluma”, it also switches the Font Style’s “Default Text Font” to “Petaluma Script”, which you’re saying I shouldn’t be using.

I guess my question is: how can I make the overall look/feel of my score in all aspects as “Petaluma” as possible (music notation/text, etc.), without getting that warning sign when I open the program?

Thanks and apologies for my confusion -

  • D.D.

Go through all the font styles in the Font Styles and Paragraph Styles dialogs, identify the ones that are based on the Default Text Font but have style overridden to Italic, and either substitute a different font or unflick the Italic switch.

I still maintain, though, that this is strange and pseudo bug-like behavior, as I don’t recall changing anything from the defaults in the first place and have only now started to get this warning when opening the session. I would simply like my entire score to use Petaluma, with all factory defaults. Isn’t there a “one-stop” “restore to factory settings” I can simply set somewhere? (just checking!)
Thanks -

  • d.D.

The factory defaults are to use Academico, which has various different font weights including Italic.
The factory defaults are also that various individual font styles are “based on” the Default Text font style, but overridden to use Italics.
Petaluma is not the factory default.
If you want to use Petaluma, and you don’t want this dialog to appear, you have to reconfigure various individual font styles to either
a) Use an entirely different font (one that has an Italic weight) or
b) Not be overridden to look for an Italic weight.

If you’re only seeing this now, it’s because you’ve only just updated to Dorico 3, or this is the first time you’re opening a project that uses Petaluma. This dialog is new in Dorico 3.

Please allow me to quote past me from six hours ago:

I’m only noticing this since the most recent “point” update last week for some reason (not since updating to the full 3.0). At any rate, when I hit “ok” after being prompted with the “missing fonts” window upon opening something it seems to sort itself out in a visually pleasing manner font-wise (I guess via automatic substitutions) so I’m going to leave things as is and will disable the warning (which I didn’t realize was possible).
Best and thanks all -

  • D.D.

For what it’s worth, I am getting the exact same warning.

Yes, you will, for any project in which you’re using Petaluma but in which any font and/or paragraph styles are set to use an italic weight. The reasons why are explained in the thread, as well as what steps you should take if you want to stop seeing the warning.

Hello Dorico Team,

I have the same problem with the warning for the fonts.

Now I have performed all steps as described, but the problem is still present.

Would it be possible to translate the instructions into German,
I might be able to find the fault.

Many thanks in advance.

Greetings
Klaus

Take a look in Engrave > Font Styles to find out which font style is set to use the ‘Wingdings’ font.

Hello, Daniel,

Thanks for the quick answer.

See attachment.

Are there other Schriftstile that use Wingdings?

No, I’ve looked through them all.

What about in Engrave > Paragraph Styles (Notensatz > Absatzstile)?

In the Engrave > Paragraph Styles I only have “Academico” and “Source Sans Pro”.

Please attach the project itself so we can take a look.