Ghost midi notes in track

Suddenly I have got ghost midi notes on two tracks in my production.
One track has Native Instruments Kontakt 5 and Studio Drummer and the other has XLN Audio, Addictive drums 2.
Both suffers from midi notes, playing but has not been recorded at all.
I have trying to restart, the computor, Cubase and myself :slight_smile: with no success.
Anyone who has experienced that and/or has an solution?

Two potential sources.

  1. You’ve got the Chord Track set to play via that track.

  2. You have a VSTi that generates midi data and shows up as a MIDI Input in Cubase. These can be unintentionally routed to a track if the track’s input is set to All MIDI Inputs.

thanks Rodger
I’ll check this.

Actually it could be none of these 2 reasons. It happened to me couple times. Some notes just began playing out of nowhere))
I would try duplicating the track - maybe ghosts won’t follow the copy.

I duplicated the track, I switched instruments, I also made a brand new track and yet it was still there.
Before this problem occured, I removed another track with drums and after that I got this problem. It became corrupted somewhere.
Now I have got rid of it but do not know how I did it exactly:-)
I wonder if this might help? To delete the contents of the Application Data folder (I think it’s called) Start Cubase again which then loads all the settings again. (Note that none of your own settings is left after that)

It’s probably a midi through issue, try setting your input to NONE for the track

I just experienced the same problem, turns out it was a part of a track that didn’t show because I either used the split tool or I shortened a MIDI region by dragging the right corner tab.

I fixed this by using the glue tool and clicking on the event a few times and wallah , there was my apparent ghost note, suddenly visible and I could delete it.

Hi all,

i tried all of the above and nothing is working for me. I am an experienced Cubase user and at this point quite flabbergasted. It only happens when record enabling a track. ANY midi track that i will record enable, will play a set of chords from elsewhere in the project, no matter what.

  • midi input is set as not connected
  • chord track is deactivated (and deleted)
  • there are no hidden parts (also: it happens on every midi track, so hidden parts seem unlikely)
  • it happened all of a sudden in a project that has been running smoothly for months
  • there are no other midi controllers connected (i disconnected every sequencer/keyboard)
  • i tried duplicating/deleting tracks, to no avail.

The project seems corrupted, as Pete Parker opted earlier in the thread. Anything i can do about it? Not being able to record midi anymore is quite devastating for this project. I can think of ways to solve the problem myself (bouncing everything to audio or saving midi clips and rebuild the project) but those ways take up hours if not days of time and i do not look forward to it at all.

Any other suggestions?

I’d try creating an empty Project and use Import Tracks From Project to pull in all the Tracks. If the problem also comes along, I try it again but import the Tracks in small bunches to see if it is related to any specific Tracks.

Another thought is if you use any Virtual MIDI Cables perhaps double check their connections.