glissando line strange look

i’m sure that there is already a topic but there are so many glissando topics that I just can’t find it.
please give me a link or please tell me how I can avoid this when changing the page or the system:


Thanx

There’s no perfect way of automating this at the moment.
In Engraving Options > Glissando Lines > Horizontal Position, open the Advanced Options. If you reduce the Minimum gap between start of system and continuation of line that might help.
Other than that, it’s probably a case of manually adjusting the gliss, in Engrave mode, or using the Note Spacing tool to give more room between the start of the system and the first note.