Glissando Playback - only 1/2 tone

I modified the group in Kontakt to Pitch Bend by 12 Semitones and it works with the Pitchwheel, but when Dorico plays it only 1 semitone of glissando is heard.
I have the Expression Map set to 12.

Also set Microtonality playback to MIDI pitch bend in the expression map, in addition to changing the Pitch bend range value.

Hi Daniel,
Unfortunately, it doesn’t work. I am attaching a System Report

Dorico (1.4 MB)

Diagnostics won’t help me here, I’m afraid, since the issue will be somewhere in Kontakt itself or your expression map. I don’t have Kontakt or any Kontakt libraries, so unfortunately I won’t be able to troubleshoot this myself, but perhaps another poster here on the forum has the same library and can offer some assistance.

which library? Your EM settings look OK and if your instrument does allow Kontakt group editing (not all do) or direct pitch-bend control like Chris Hein libraries to extend the pitch bend then it should work in Dorico. I have several libraries which do. Does it work in a DAW or are you not able to test this?

Hi, I did the group editing in Kontakt as shown in the attached picture, maybe something is not correctly set up.
It’s Spitfire Solo Strings.

quoting from a post on Spitfire libraries in VIControl:
Go to the “Instrument edit mode” → then click on “Group editor” → click on “Edit all groups”

Click on “Mod” in the “Source” area (where the DFD, tune and tracking settings are) → then click on “Add modulator” → then on “External source” → select “Pitch bend” and that should be it.
You can change how far your pitch bend goes (from 0 to 12 semitones, default is set to 2)

As fas as I can see from your screenshot, this is what you’ve done but you might want to double-check. Unfortunately, I don’t use the Spitfire solo strings so can’t test directly.

Does the pitch bend show correctly in the pitch bend lane? For instance if you use a full octave (12 semitone) range then the value at the top should be 100 as shown in the screenshot. Everything else should be in the proportion 100/12 =8.33 for each semitone. If necessary, you can simply manually add the appropriate lines. If doing this still doesn’t work, then there is something up with your Kontakt setup, although it looks like you know what you’re doing.

If you’re still unsure, you could post the project (or a relevant extract) and I could check this aspect of things.

Hi @dko22,
Thanks so much for your help.
The file is too big to upload here.
When I do Pitch Bend with the Hardware MIDI controller I can do the Full Octave, but in Dorico it only plays a 1/2 tone glissando when I write a glissando that spans an Octave. Also, it doesn’t play the 1/2 tone glissando when I write a glissando that spans a 1/2 tone.


if the file is too big you could either a) just save a short extract which demonstrates the problem b) upload it to any file sharing site or c) apply the silence playback template which normally greatly reduces the size of the file. I still think it would be easiest to see the file unless others have other specific ideas?