Globally/Locally Switch: Bug? Or user error? :)

I am trying to create text that only appears in my score, and none of the part layouts. This is text that is linked to the music, so I don’t want to do anything page-oriented like add Text Frames (which was suggested to me on Facebook). Here is what I am doing:

  • Enter some system text.

  • Turn the switch at the right of the properties panel to the ‘Globally’ scope.

  • Hide the text. At this point I have confirmed that the text is hidden in all layouts

  • In the score layout, switch the local properties switch back to the ‘Locally’ scope.

  • Toggle the ‘hide’ switch off in the score.

Now, if I am understanding everything correctly, I should now have achieved my goal… Except when I check the parts the text has been unhidden in all of them, like it didn’t matter that I flipped the switch back to ‘Locally’.

What’s even stranger is that with it now set to ‘Locally,’ if I hide the text it is ONLY hidden in the score, so the ‘Locally’ setting really is working as expected there!

Any help is appreciated… Or even confirmation that it’s a bug!

As a follow-up to my own question… Text is really only the beginning, I’m also interested in having other elements appear only in the score, like lines and symbols for streamers and punches in film scores. Text is as good a place as any to start though…

As far as I can tell, this isn’t a bug. Properties set locally are overruled if they’re then set globally, as per Local vs. global properties

To save switching back and forth between layouts, I think you could
a) add the text in the score
b) locally hide it in the score
c) Edit > Propagate Properties (which will copy the local hide property to all other layouts without actually making the property global)
d) Unhide the text - still locally - in the score.

Bear in mind that properties can be set/propagated/unset for multiple text items at once, and that if you Alt-click/copy and paste an item it will retain its properties. In the case of text items this holds even if you subsequently edit the text.

I’ll try the propagate thing in a moment, but Leo I still think it’s a bug: If the property is set globally, and then changed locally (in that order), it should only change locally, NOT globally. And like I said, the behavior is not consistent, because it seems to work one way for hiding things, and a different way for un-hiding things. Maybe after dinner I’ll put together a quick video illustrating the problem.

Here’s a video demonstration of what I’m talking about, showing both the case where things work as expected, and where they don’t.

Hi.
I watched your video (without the sound) and it’s working exactly as designed.
Then I listened to a bit of what you say, and I think you’ve missed a part of how this works.
Please notice how the globally set property ui turns to bold white. Once it’s been set, no matter how you change the global/local preference setting, note that it dtays bold (global) if that’s how it’s been set. Even though it’s not convenient for your workflow (that you’ll eventually change — following Leo’s advice is usually a good idea when it comes down to using Dorico), it’s the only way to keep the granularity in those settings. Some will remain global, others local, and those you have not touched keep the ability to be changed locally or globally independently, when needed.
When set locally, the property ui is white but not bold.
If you follow Leo’s advice, hide your text locally and propagate the property, that property will retain the non bold ui, and you’ll be able to unhide your text in the score only.
I hope my rephrasing will help you understand (although I am French and not really woken up yet).

Hi Marc,
Yes, I know that if I toggle the switch it turns white, but I maintain that it is behaving completely differently when going from toggled on to ‘Hide’ than when it is toggled off, with respect to the ‘Globally/Locally’ settings. Let me see if I can present the problem one more way:

  • When set to Globally, switching ‘Hide’ in either direction affects all layouts in the same manner. That is a global change, so it is working as expected… or at least as I expect!

  • When set to Locally, turning ‘Hide’ on will hide the text in the current layout only. That is a local change, so it is working as expected… or at least as I expect!

  • When set to Locally, turning ‘Hide’ off will show the text in ALL layouts. That is a global change when it should be LOCAL according to the settings. It is therefore NOT working as expected!

I have nothing against trying (or using) Leo’s method of propagate to parts, but I still think this behavior is a bug, and I will continue to do so until a developer tells me otherwise :slight_smile:

Ugh… OK, @MarcLarcher, you’re right, I see it now. I see the bold vs. non bold.

Here’s what irks me about this is the order of operations. The way you said it above, @pianoleo, is that “Properties set locally are overruled if they’re then set globally.” That’s fine, that makes perfect sense to me.
But in this case I’m doing it the other way, so it’s more like “Properties that are set globally even once can NOT be overruled locally later on”. Which seems really wrong!

Well… Guess what? @pianoleo the propagate properties approach isn’t working either. It works initially to propagate the ‘Hide’ switch, but then as soon as it does it appears bold as @MarcLarcher pointed out. Switching ‘Hide’ off to show the text at that point still makes it show in every layout.

Here’s another video (no sound this time):

You’re right, propagate properties is like toggling “Globally enabled” properties switch. I guess you have no choice but going through every part where you need to hide locally that text!
I know it seems a PITA, but it’s important to keep granularity in those settings, and the bold/non bold thing is quite important, to be sure you’re not messing other parts or score…
Anyway, I don’t think it’s a bug, but I’ll let Daniel correct me if I’m wrong.

I have to ask then, why are you using System Text instead of just using just SHIFT+X text only in the score? You might even want to create a single-line staff solely to attach this text to, much as some composers create a single line to attach measure numbers to.

I actually did try adding an extra staff earlier and wasn’t happy with the results. I put in an extra bass drum at the top of the score because I didn’t want a whole 5-line staff, but I can’t hide the clef (I tried right-clicking and selecting ‘Clef>Transposed Clef>Invisible Clef’ per an earlier suggestion from Leo, that didn’t work…), and it COMPLETELY messed up the behavior of the large time signatures, which are set to be once per bracket (I suspect it’s because the bass drum was an instrument ‘between the brass and strings’ which I had set to display only one time signature). Anyway, without better control over the extra system that didn’t work acceptably.

I still may resort to using staff-attached text fewer things to hide), but there really should be a better way of doing this. As I understand it, at some point there was the intention of making a ‘conductor panel’ that included some of the conductor’s marks as well as analysis tools… I’d love it if the developers would add that functionality, and include the ability to add text and markings just for the conductor.

UPDATE: Staff attached text works fine, but staff attached horizontal lines for streamers do not, as there isn’t a way of hiding them in the properties panel.