GM Soundbank. I likey!

I thought the new GM soundbank might be just an updated “Universal Sound Module”, but it has quite excellent sounds (certainly for my ‘ambient’ ‘soundtrack’ type uses).

Nice job HS devs! :wink:

I’ve only tested the update for an hour or so, but one vocal patch has an odd note. I was playing some chords and I thought: “Wait! Where the h*** is that horn sound coming from? I don’t have any brass loaded.”

I stopped playing and then played each note up and down the scale. At the C3 octave transition (and only on this note) there was a distinct brass like overtone.
It seemed to be in the sample itself, as opposed to anything synth engine might be doing.

When I do some more testing I’ll update this post with the name of the patch. (I should have jotted it down but I was too busy checking out the new goodies). :slight_smile:


hello, could you tell me how active the program changes with HS ?
I would like to load a midifile and obtain automaticaly the good GM sounds ?

tell me please if it’s possible or not.
:unamused: :unamused:

I’ve only had a quick play but it seems to me that you have to make a note first of the instruments and their MIDI channel in your file and then load those accordingly in HS; i.e not a major step forward. So, you can load the new patches prefixed ‘GM’ if you like, although obviously you can load whatever patches you like of course (so why designate some as ‘GM’?).
All that tells me I might be missing something here and that you should be able to load a SMF and HS should respond by loading the correctly mapped ‘GM’ patches, but if that’s the case I can’t see how that’s done and I can’t find a reference to it in the PDF manual. No doubt someone from Steinberg will come and enlighten us!


thanks for your answer, I will wait for someone from steinberg, because I note the PG N° in the track but it’s not efficient like that.


to switch to GM mode, go to Options, check GM Mode under Global.
Then load a midifile into the player and start it.
All sounds load very fast!

Gr, Mike

that’s correct loading a file works fine. But using the standalone host application and sending program changes through the MIDI device defined in MIDI Input shows with the flashing colour of the selected channel that Halion Sonic host receives the command but does not react on it by loading/changing the patch requested. General Midi mode is selected of course on the option tab. Might be there is filter option for incoming MIDI messages where PC is disabled? - But I could not find such a filter. Or, it does simply not work yet?

Regards, tomotello