Grace note playback (acciaccatura)

I seem to have a problem getting the very first acciaccatura to play at the very start of the flow. It plays fine on the repeat, but doesn’t play the first time round. Changing it to a appoggiatura rather than a acciaccatura works fine, but not as an acciaccatura.

Weird. Is this a bug?

Thanks

V

Edit: project added
acciaccatura issue.dorico.zip (427 KB)

It is designed behaviour, but there are two things you need to do to get the acciaccatura to play the first time:

  1. In Play / Playback Options / Timing / Flows, set “Pre-roll before flow” to enough time to play it (the default is 0 seconds).
  2. When you play the flow, don’t select the first note, do “Rewind to beginning of flow” (press “.” on the numeric keypad, or click the icon on the top toolbar to the right of the tempo display).

Thanks.

Unfortunately I only have Dorico Elements 3 so I’m unable to change the pre-roll.

Weird that the appoggiatura plays OK but not the acciaccatura. Is this designed behaviour because the acciaccatura has no notional time value, but an appoggiatura does; thus one automatically adds a little pre-roll, but the other doesn’t? I don’t understand.

Thanks

V

No. The acciaccatura comes before the beat, whereas the appogiatura comes on the beat. Unfortunately, without setting the pre-roll, there is no time before the first beat of the flow, so Dorico can’t play the acciaccatura.

An acciaccatura doesn’t occupy any “written time value” in terms of counting the beats in the score, but when it is played, it takes up some “real time” which has to come from somewhere. In the middle of a score, that time is taken away from the previous beat, but right at the start there isn’t a previous beat.

If you want to export audio and synchronize it with something else (for example, use it on a movie soundtrack) you need to know exactly where the exported audio track starts, and by default that is on the first beat of the first bar.

Since an acciaccatura is played before the beat, you have to move the start point back to get the grace note to play.

The playback duration of the grace note itself depends on other parameters in Dorico (which you might not be able to change in Elements) so “the start of the grace note” is not a very well-defined point in time, but setting the pre-roll to say “0.5 seconds before the first beat” is well defined and you can still line up the audio track exactly, allowing for the 0.5 second time offset.

You can work round this for playback in Elements by inserting an empty bar at the start of the score.

Thanks.

I thought of that. But this would probably be a bit messy, and there’s a section repeat and a D.C. Repeat in the piece which might be a bit tricky.

An option in Elements to add a bit of pre roll (fine control not required) such that it actually plays ALL the scored notes would be helpful.

Playback of grace notes also works across flow boundaries. So if you create an empty flow (with a single beat for instance) prior to your current flow then you can hear those notes on playback. This might work better for you rather than an empty bar.