Grace notes and free playback


With grace notes/groups, Dorico tries to change their relative length to make them grace notes. If you manually adjust the playback length and position, it continues to try to adjust it according to its algorithms.

Is there a way to disable automatic interpretation for grace notes, so that one can manually adjust their length and position? The available options for grace notes in the Playback Options seems not to do what I’m looking for.


I’m not sure what you mean, Paolo. Once Dorico has determined the length of the grace notes for playback, you should still be able to adjust their position and duration thereafter, as the start position and duration properties are deltas on the calculated position/duration. They should still apply.

Daniel, sometimes it works fine, but some other it seems to be unpredictable here (Mac, High Sierra).

For example, this is what just happened in a news score with default settings:

And this is what happens when I try to adjust grace notes in a more complex score (that I can send you as a private message, if you like):

Grace note length and position change


Certainly pictures and videos won’t allow me to diagnose the problem, I’m afraid. They just serve as a reiteration of your description of the original problem.

I think the stave (staff) needs to be connected to an end-point for the play display to be (more) correct…

I don’t know, but they are connected to an endpoint configuration.


Not according to your picture above…

Oh, I see. You are right, this is a test file with no output connected.