gray line at certain % of zoom

Hello,
At some % of zooming some staff lines are grey
As I’m coming from Sibelius. In sibelius the problem was solved by un-ticks In preference/Display/Smooth staff lines,barlines and stems. Is the an equivalence in Dorico?
thanks
Dup

Hi,

I don’t see any settings in Dorico which do what you’re looking for. That setting in Sibelius was an ‘anti-aliasing’ setting (although not called that by name).

Your OS and graphics card have a big role to play here. So in absence of available settings within Dorico, I think the only option would be to see if there’s a control panel associated with your graphics card drivers… If you do have one, there might be a couple of settings which you could try to adjust there.

Having said that, I’m not so sure what your seeing falls into the anti-aliasing realm. it might be something of a different nature.


Take a look at this discussion from the Sibelis Forum… http://www.sibelius.com/cgi-bin/helpcenter/chat/chat.pl?com=thread&start=612173&groupid=3&&guest=1 . . . for a good overview about what’s happening with the smoothing setting.

Hi Jim,
Thanks for your answer, but I had all ready read the article in his time. before I untick the smooth in sibelius preference display.

Having said that, I'm not so sure what your seeing falls into the anti-aliasing realm. it might be something of a different nature.

I’m really not sure, because I haven’t this probem in other program ( sibelius, finale, cubase…)
grey line A.png
and with notes at 150% :
grey line with notes 150percent.jpg
best regards
Dup

Hey Dup !!
:stuck_out_tongue:
I can confirm the blur on certain lines at 150% zoom (only)
Although here I get it on E and B when notes are present and G and D when empty bars

For the moment don’t use 150% Zoom
:sunglasses:

Hi SeeWhat,
Happy to see that you also took the train of this new software, which incorporate the best the rules of music, I never seen in other engraving notation software.
For the problem of blur lines I also have it at other % than 150! till 200% sometimes good at 180%
Best regards
Dup

Dorico’s drawing routines always use anti-aliasing, and when they fall at sub-pixel positions, you may indeed see some staff lines drawn in two rows of grey pixels rather than a single row of black pixels. We do have an option to disable anti-aliasing of straight lines on our backlog for the future, but it’s not one of the highest priority tasks, and in any case, you would be trading off one problem for another, because if you disable anti-aliasing for straight lines and force staff lines to be drawn on pixel boundaries, you will instead see uneven spacing of staff lines at those zoom levels, which in my opinion looks much worse.

Hi,
Thanks for the answer. It’s only a little annoying for me because I often use “print screen” of a selected a passage and incorpore it on webpage or pdf.
Perhaps an option export/print selected passage could be great.
Another point the print as graphics as option is good as pdf but not in tiff or png: why?
it creates "crackle* créneau on 16th see examples and comparison btween print screen and print graphics:
print screen.png
and after print as png graphics
print graphics_png.png
Best regards
Dup

The quality difference between the PDF and the PNG is probably because you have selected “Mono” for the PNG. With the mono setting, Dorico uses only black and white pixels, so there’s no antialiasing.

By the way, there is a kind of workaround to get Dorico to export black staff lines, but it’s a little tricky. If I export a (Color) PNG with default settings, it looks like this:
Gray lines.png
(I trimmed the PNG and changed the background to white in an image editor.) All staff lines are gray, but they’re gray in the same way. What’s happening here is that the default export resolution for PNGs is 72 dpi, which means that 1 pt = 1 pixel. And the default space size (for the score) is 5 pt, which means that the staff lines are exactly 5 pixels apart, but they are all drawn right on the boundary of two pixels, so antialiasing gives us two gray lines.

But now, go to Engrave mode, and with the help of the Properties panel, shift the top of the music frame exactly 0.5 pt. For example, mine was at 75 pt, so I moved it to 75.5 pt. Now all the staff lines fall right in the middle of a single pixel, which gives us one black line. The exported PNG looks like this:
Black lines.png
If this resulting image is too small for you, you can go to Setup mode, and increase the space size. However, the space size needs to be a whole number; otherwise this trick won’t work.