Grid not working correctly with Groove Quantize extracted from Audio

Steps to reproduce:

  • Create an empty project
  • Import an Audio file with rhytmic elements, a drum loop is fine
  • Open Sample Editor
  • In the Hitpoints tab adjust settings to obtain an hitpoint on every drum hit
  • Create Groove
  • Open a MIDI or Instrument Track
  • Create a MIDI Part
  • Open Key Editor
  • Choose the created Groove Quantize as preset
  • Open the Quantize Panel

Result:
Compare the green vertical lines in the Quantize Panel with the grid
In almost every case the grid displays less vertical lines than the quantize panel even adjusting the zoom. If MIDI notes are added with Snap enabled they snap correctly but to an invisible grid line.
Following I have uploaded two pictures. In the first one you can see the grid compared to the Quantize Panel, in the second one I’ve highlighted the missing lines of the grid, but in both pictures can be seen that the notes that I’ve created line up correctly even without the visible grid line.
If necessary I can even provide a project.

This bug is present since Cubase 10 Pro through Cubase 13 Pro. I’ve tested it mainly on Mac, but it appears to behave in the same way regardless of the platform and version of the OS and I’ve experienced it on dozens of different computers


1 Like

Yes - it makes working with grooves pretty difficult. Any solutions to this?