Groove Agent 5 crashes Cubase 12.0.52 every time and Steinberg doesn't have a real support

Thank you. That helps. I was uninstalling and reinstalling clean with the same result, thinking I missed something.

Looks like we have to wait for a fix.

There was a new version of MediaBay released in the past few days. It might be worth running Steinberg Download Assistant, letting all auto-updates install (which should update MediaBay), installing any other updates offered, and trying again. Does the problem still happen?

2 Likes

Mr W
You have made my day , I have been trying for the last half an hour to get groove agent to crash with loading individual outs , loading 1/2/3 GA’s swapping presets , loaded loops , sliced , added induvial outs rendering ,rendered 5/6 times and will it crash ???

NOOOOOOOOO :upside_down_face: :heart: :+1:

One problem still persists and that is if you assign the drum pads via the main page to an individual out then those drums can only be rendered once but the work around is to render by assigning via the pad instead .
Will do some more testing but already this is very good news this end

1 Like

Hi David,

Yes, I am still experiencing the crash. The crash always occurs when changing kits.

I believe there is something wrong with the USB dongle license support. But I don’t know.
I am ready to try the SEL licenses instead.

What I have done is removed everything Steinberg from the Mac Studio. Then reinstalled everything using the download manager. The media bay update was done as well.

Here are the crash reports.

Cubase 12-2023-03-24-021504.ips (63.2 KB)

I got Groove Agent to stop crashing.

What I did was remove Groove Agent 5 SE and Halion Sonic SE. I have the full versions, so I figured why not.

Initially I made sure not to install them or their content with the Download Manager. But I still was getting the crash.

So I searched the Library and found and removed the SE VSTs, the dependency files, (Groove Agent SE 5.dependencies) and (HALionSonic.dependencies) and any other files titled Groove Agent SE and Halion Sonic SE.

This is the first time I have been able to go though all the stock Groove Agent 5 kits, all my paid expansion kits and back and forth using the all agents media bay without crashing.

So maybe there is/was something corrupt in the SE stuff.

It worked for me. Something to try anyways. I usually don’t go hacking, but I was desperate. The crash logs seemed to indicate a license check issue, so I figured, start hacking out stuff to see what it is. The SE stuff was the first on the chopping block. And that seemed to work for me. :slight_smile:

I do not recommend this method. Groove agent IS working for me now though.

This is good to hear as the Media bay update really has sorted out the issues i was having before , strange how the mediabay affected so much but , a day pressure testing and everything’s fine . Did you download any updates in the download manager ?

I did do the updates in the download manager on both of my Mac computers, but that did not do it for me. I still had the crash when changing kits after the updates.

This was 2 new installations on 2 new Mac computers, a MacBook and Mac Studio. I can only speculate what was happening because I am not a software troubleshooter.

It appears there was some kind of a license check issue on my end. From what I gathered from the logs, it looked like the license check was aimed at an incorrect path. Or perhaps it was seeing one thing and not the other, like the SE version and not the full version. Heck I don’t know.

Taking out the following files seemed to cure the issue for me. I don’t know if it can help others. The result for me is that the latest Halion 7 and Groove Agent 5 are now working with Ventura 13.2.1 (Native) with Cubase 12.0.52.

Again, I don’t recommend hacking out files. But this method worked on my end since I am using the full versions of Halion 7 and Groove Agent 5.

I’m afraid it’s still crashing BUT this was with 4 instances of GA5se open with 32 individual tracks

Cubase 12.0.52.393 64bit 2023.3.24 12.23.41.621.dmp (1.5 MB)

Yeah, seems like some sort of an “invalid pointer read”. I was having a similar issue on Mac, but I have no idea if the issue is related.

The crash for me would happen when switching kits. Not every kit, but on certain kits, it would crash. I have no idea which ones.

Yep i was having similar but the mediabay has been a vast improvement , the crash dump does mention about graphics and framework again but it’s taken 4 instances to break it instead of just loading once from the browser .
I have an open case with Steinberg tech anyway so this has been reported

I have a case open as well. It will get sorted out.
I do welcome all the updates. It is worth the growing pains IMO.

Well support say mine was cause by an Exitdll , told me to do this then closed the ticket :upside_down_face: :rofl: :joy: He must be pretty confident it will work lol

I just had minor success working through Groove Agent SE crashes. I had some kits that caused it but not others. I went to mark the kit as one star in the kit browser (as a reminder not to click on it) and that brought up a “licence about to expire message” and then successfully loaded the kit. If I click on the kit name, Groove Agent hangs. The hanging problem persisted through re-installing Cubase 11 Pro, re-installing Groove Agent SE 5.1.20, and switching to different audio interface. I suppose I could buy the kit as well… (Prime Cuts)