Groove Agent / Dorico 5 Issue

When launching Dorico 5, I’m seeing the message about missing groove agent… it’s installed… I’ve re-installed, but the message persists.

Other than ticking the box to ‘do not show this again’, how do I resolve this and ensure Dorico is seeing Groove Agent?

1 Like

Ah, I see this is actually a message about the ‘Content’… but that’s installed too…

Please do Help > Create Diagnostic Report and attach the resulting zip file here, so we can take a look.

Thanks, @dspreadbury !
Dorico Diagnostics.zip (151.3 KB)

Dorico is definitely being told by the audio engine that the Groove Agent content is not installed. Please run Steinberg Library Manager and check that everything looks OK in there (click the Groove Agent button at the top to see the Groove Agent content). If it does, you might consider checking the permissions on the content files shown in SLM to make sure that they are readable by all user accounts on your computer.

I found some files that had no ‘Users’ account associated w/ it… I applied at the root C:\ProgramData\Steinberg\Content folder… and applied to all sub-elements… but still seeing the error.

Is there any more definitive info about what file(s) need access in this update Diagnostics file?
See attached screenshot… to make sure I’ve got permissions set as expected?


Dorico Diagnostics.zip (171.5 KB)

That looks correct to me, but perhaps @Ulf knows a bit more than I do.

Could you please run additionally the attached batch file (unpack and do a double click on it, after a few seconds another zip file gets created on your desktop) because that one gives me more info on the installed contents. Thanks

CreateVAEDiagnosticsReport.bat.zip (817 Bytes)

@Ulf -
I ran a couple of times, but even w/ the console showing it wrote a file to the desktop, no file is to be found…


@Ulf -
could see that the batch file was trying to create a folder on the desktop named: VAETempInfo… I created this folder manually, and re-ran… a number of files showed up in there… so I zipped that folder, which is attached.
VAETempInfo.zip (8.0 KB)

I also ran it from the command line, and redirected the output to the attached log.txt file
log.zip (2.0 KB)

Hi @DoYouLikeHam , thank you for the data and yes, it is sufficient.
So the access rights look good, but there are still some GrooveAgent files missing:
FCPSMT137GrooveAgentSE.vstsound FCPSMT152GASEAcousticStudioKit.vstsound FCPSMT214ProductionGrooves.vstsound FCPSMT215ProductionGroovesKits.vstsound
FCPSMT775GASETheKitSEPresets.vstsound
FCPSMT779GASELaserBeams.vstsound
GrooveAgentONE01.vstsound
GrooveAgentONE02.vstsound
GrooveAgentONE03.vstsound

I recommend to download and reinstall the GrooveAgent contents once more.

Thanks, @Ulf … there are in fact files in the content tree that have names suspiciously similar to those… see attached, and as enumerated below:

FCPSMT137GrooveAgentSE.vstsound > FCP_SMT_137_Groove_Agent_SE.vstsound
FCPSMT152GASEAcousticStudioKit.vstsound > FCP_SMT_152_GASE_Acoustic_Studio_Kit.vstsound
FCPSMT214ProductionGrooves.vstsound > FCP_SMT_214_Production_Grooves.vstsound
FCPSMT215ProductionGroovesKits.vstsound > FCP_SMT_215_Production_Grooves_Kits.vstsound
FCPSMT775GASETheKitSEPresets.vstsound > FCP_SMT_775_GASE_The_Kit_SE_Presets.vstsound
FCPSMT779GASELaserBeams.vstsound > FCP_SMT_779_GASE_Laser_Beams.vstsound
GrooveAgentONE01.vstsound > Groove_Agent_ONE_01.vstsound
GrooveAgentONE02.vstsound > Groove_Agent_ONE_02.vstsound
GrooveAgentONE03.vstsound > Groove_Agent_ONE_03.vstsound

tree.zip (1.3 KB)

in fact, here are the file security properties of the first one on the list:

And… all the files seem to be configured properly into Library Manager…

Nevertheless, I reinstalled from the Steinberg Download Assistant with the same results.

I’m at the moment at my smartphone, can you please clarify? The output to the command I’ve sent you says for example :
GrooveAgentONE03.vstsound > Groove_Agent_ONE_03.vstsound
The names are very similar but not same. The installed filenames are with underscore whereas the file that Dorico is looking for is without the underscore. Are the installed sound files real files or only symbolic links?

1 Like

@Ulf - sorry, I don’t know if they are symbolic links… they are simply how they were installed w/ the Steinberg Downloader / Installer… the names as shown in the previously posted image of the Library Manager shows underscores, and the files in the folder also have underscores. If they are being installed w/ underscores, why is Dorico looking for files w/o underscores?

Sorry, that is all pretty weird and I need to ask my specialist tomorrow on this. I’ll be back…

@Ulf - agreed… weird. Thx for your consideration over the weekend!

Sometimes these files get installed with spaces in their names, sometimes with underscores, so Dorico looks for them by finding all of the files and then removing all spaces and underscores from their names. That explains why the filenames shown in Dorico’s application log might not match the precise filenames of the files on your disk.

I am pretty certain that this must be a file permissions issue, since the files are present.

Just to share w/ others the outcome here.

I had the great pleasure to meet w/ @Ulf and we worked through it.

What ended up working is clearing the default location in the Library Manager, and Removing all the Groove Agent libraries… also removed the previously downloaded installer files just for good measure… then re-installed through the Download Manager, and all seems to be working.

2 Likes

I got the almost exactly same problem, but seems dorico tells me, I lost more things.