Groove agent not including complexity of track all of a sudden


I’m using Cubase 7 and the Groove agent (purchased to not the SE version). I was recording a tune and all of a sudden if I adjusted the complexity of a beat (pad) and then dragged and dropped it on to the track, the track was at the simplest complexity (or just something that didn’t sound like the preview). it just seemed to happen in this session and I don’t recall hitting anything that would have adjusted the settings but am wondering if I may have by accident.

I was running it as a VST instrument to midi tracks (not as an instrument track) and I have midi channel 1 for a percussion set and midi channel 2 for the drum set. the midi channel 2 is what was not working all of a sudden and I had adjusted the complexity prior in the tune/session and it worked fine.

When I shut Cubase down I did get an error message and restarted it and still the same thing. the wired thing too is that when I drop it on to the track it seems to even miss some overtones (like toms or something) long being played more simplistic than even the simplest version when I play off the pad in GA. it seems to be acting a bit weird overall.

is there something I’m missing. If I’m missed posting any pertinent info too let me know and I’ll let you know. Any help would be appreciated. I dig the option to be able to adjust that in the track to help bring the mood up and down so it would be a real bummer to lose.


I just realized at the top of the forum there was a thread for an update for Groove agent, will also give that a go when I’m back at my computer.