Groove Agent only working with template.

Hi I am using GAOne to compose drum tracks for demos. I have succeeded in creating final mixdowns to MP3.
If I take an existing project and save as new project and start from there deleting the old project tracks I don’t need all is fine. If I try to set up a new project from scratch and then insert the VST instrument-GAOne track I just cannot get the “edit drum track” window. The instrument pad editor is accessible and all the other settings ins/outs are identical to the settings in the cloned project. I can’t for the life of me see where I’m going wrong or what is set differently.
Have I missed a hidden setting somewhere?


Do you mean Drum Editor?

You have three options:

  1. Menu MIDI > Open Drum Editor.
  2. Setup your sound in Groove Agent One, and select a Drum Map. Now, once you double-click the MIDI event, Drum Editor opens. There is a preferences > Event Display > MIDI > Edit as Drums when Drum Map is assigned, which is enabled by default.
  3. In Preferences > Event Display > MIDI, set Open Drum Editor as Default Edit Action. Then all MIDI tracks will open in Drum Editor.

Hi Martin
Thanks for your reply.
Yes all those methods work for the template version but not the new project version. The MIDI>Open drum editor is not in bold type so can’t click it. I now think the problem is that there are no existing events with a new project and so I should focus on how to get an event in the first place. With the copied and “saved as” template there is already an event to modify in the track so I can cut/select/copy/modify events along the timeline of the track to suit the new song. With the fresh project the track is empty of events. If I press record and click pads on the GA window I get sounds in my headphones and I see the event appearing on the track but there are no notes showing and when I stop recording the event disappears. To be honest I’m not even sure that I’m trying to enter a new event correctly. The parent version of the template was made all that time ago in the old LE that came bundled with the Lexicon Omega and perhaps I’m overlooking something in this newer version. Maybe I should read the manual more.


All of these Commands are available only if any MIDI event is select. The editor of the event opens, nit editor of the track.

Groove Agent pads (same as virtual MIDI keyboards of any Instrument) don’t send the MIDI data to the Input of the MIDI/Instrument track. Please use Cubase Virtual MIDI Keyboard (with your computer keyboard) or any MIDI device.

Or you can draw an empty MIDI event, and inser the MIDI data in the editor.

draw an empty MIDI event

Thank you for that prompt. For clarity of thread resolution: I selected the pencil pointer and swipe/drew an empty event. Now I get the option of editing and inserting notes. Sorry for my dimness as usually I just record audio from USB interface. Thank you for your patient help.
:smiley: :smiley: