Groove Agent performance issue

When my one shot samples from media bay are triggered by my midi tracks, the song position pointer pauses. It doesn’t affect audio playback, but every time the snare drum is triggered for example, the song position pointer pauses for a second, almost like it can’t hit the snare and the hi-hat at the same time, so i’ve got a huge Charlie Watts issue right here. I can swap samples around and the problem shifts to another sample, like a kik, or a tom.
It seems a bit random, sometimes it will smooth out, but mostly the song position pointer is just jerky right across the timeline. Mute the midi track and playback is smooth again.
Media Bay database issue? Drive issue? Any suggestions?
Groove Agent SE behaves the same.
Brand new Build - Windows 11, Cubase Pro 12, Samples are on a fast 2TB NVMe Drive, Asus z690 motherboard with intel 12900k chip, Nvidia T600 video card.

Update : When i click ‘create database’ in Media Bay, i get error “Database Creation failed because the target is write protected”. Is there a detailed method to give cubase full write access to my samples drive? Under windows properties this has already been done for all users, but i;ve not drilled into policy editor etc. Launching Cubase as Administrator cause a few eLicencer errors, and also did not solve the database write issue

I would suggest making a separate topic for your volume database creation issue. It’s also not recommended to run Cubase as administrator anyway.

Are these custom samples? What’s their sample rate and bit depth? Does changing the Disk Streaming settings in the Groove Agent options make any difference?

1 Like

Thanks for the tip, that did it. Cranking the streaming all the way over to ram. I feel like an idiot!! Samples are a mix of 44.1 and 48, all short one shots, never been an issue before, but i’ve never needed to look to the options tab before now. It’s an NVMe drive and it’s crazy fast, but i’ll take the RAM fix tweak, i have 32gigs of DDR5. Brand new system, few little teething problems like this slowly getting sorted.

Update: fix was short lived. New song, same and different samples and it’s doing it again, even with RAM setting maxed. If I solo GA and the pad / channel, and file/export the sample onto a new track, then drop the new sample back on the same pad to replace it, it fixes it, so must be something to do with the integrity of the initial wave file or something, at last i have a workaround, albeit very cumbersome to potentially have to resample all of my samples in each session i open.

Updating again: The issue above is so bad in my system that i need to ditch Groove agent completely and use Battery instead. It’s happening so often that samples i drag in from my media bay just make Cubase pause for a micro second when Cubase triggers the note. It takes too long to re-export my samples and drag them back in just to make this visual issue go away. The exact same samples in Battery play as you would expect. This did not happen on my old system at all. It is shame, i’ve been using GA as my primary one-shot sampler for over a decade, but i cannot have the song position pointer and all my mixer meters freeze every single time that kick or snare or tom or hi hat gets triggered… it’s so weird