Groove Agent Sample Length Setting?

Hi everyone!

I am pretty familiar with Groove Agent but one thing has me stumped: how do I set things up so that my MIDI note length in my MIDI Editor defines the playback length of the sample being triggered?

I understand the different sample playback modes (one shot, no loop, continuous, etc) but no matter what setting I use, the MIDI LENGTH does not accurately control the sample length so that when the MIDI note ends the sample also is totally silent - there seems to always be a bit of a tail after the MIDI note has played - this is frustrating because kick samples’ transients get muddied up by the notes before them.

All help very welcome!!

p.s. if there is a way to have one MIDI note automatically go off when another is played that would also be a help.

Hi,

Sample > Until Release (default value is the One Shot).

Hi Martin, please see the attached photo - one can clearly see that the bounced audio is longer than the MIDI note. I did this bounce with Until Release set and it is not working. That little bit of audio at the end there that spills over is exactly what I want to avoid. Any other ideas? Thanks!

Hi,

I’m sorry, I’m not Groove Agent expert. Is there any Release Time parameter?

1 Like

I can’t tell what kind of track you have that sample in, but either in Groove Agent or in a Sample Track you can just drag the Sample End marker over from the right side to define the end of the sample. Hope I’m understanding you correctly:

image

The reason for that little bit of audio at the end can be found in the “Amp Envelope”.
release time to zero

If the animation is not visible click the image once.

1 Like