Groove Agent SE 5.1 Missing in Cubase 12 Pro

I have checked in the plugin manager and VST Instrument section and cannot find Groove Agent SE 5. Halion sonic SE shows up but no Groove Agent or Retrologue for that matter. I have reinstalled via Steinberg Download Assistant and by direct download but still no luck. Anyone else here have the same problem?


To update, I installed Cubase Pro 12 on my Macbook Pro. All the Steinberg plugins work fine.
I don’t understand why they don’t show up on my Windows 10 installation.


Try to install it as administrator (on Windows), please.

I assumed you meant run the SDA as administrator as that’s the way I installed Cubase Pro 12 and its components. Either way, that didn’t work. I still don’t have access to Groove Agent SE 5, Retrologue or Padshop.


Can you see the installer in the Downloads/Steinberg/Windows/ folder? Can you install it manually?

I installed it manually, but it still doesn’t work.

Some of my third party plugins don’t show up at all and my izotope Neutron 3 crashes Cubase Pro 12.

I’ve gone back to Cubase 11. I have no confidence in 12 and should of held off upgrading till these things were sorted. However, I was not to know what would work and what wouldn’t.


Make sure, you have the latest update installed, please.

Could you share the crash/dmp file, please?

It’s now working? I’m asking because my groove agent Suddenly gone. And i dont know what to do To return it.

Hi and welcome to the forum,

Download it from the Steinberg Download Assistant and install it, please.

Unfortunately (or fortunately) I had a hardware fault on my computer and was forced to reset Windows 10. This wiped all of my apps. It took me close to a week but I got everything (I think) installed back to how I had it. Now Cubase works beautifully. I even updated to Windows 11 and have found my install to be more responsive and, so far, reliable. Not a fun exercise but an idea if you’re having issues with Cubase Pro12. A complete reinstall of your OS may be the answer.

1 Like

I don’t know why but eventually (after the updates?) Cubase became a cpu hog and caused audio dropouts and overloads even with a large buffer size. I updated my audio device’s driver (Behringer XR18) but that didn’t help. I have the latest update 12.0.40. In order to finish the work I was doing I went over to Ableton Live 11 (I have it for live work). I put the exact same project on it and the cpu level was around 55%, very stable (no crashes). If Ableton had ARA support I would cross over for good.