Group Track does nothing

I add a group track and put my two audio tracks under it by dragging the Audio tracks so the group channel goes green.

Nothing happens when I use the group track’s fader or when I put FX in the group track.

P.S. I did it the Dom way by using the mixing desk.

What gives?

Did you add the group track by right clicking on the selected tracks and choosing add group track to selected channels? If not, you have to separately route the audio output of the channels to the group track.

Yes,I worked out that way.
Wouldn’t have a clue how to route them manually.

I think I know now.
It’s in the routing setting in the channel to the left.

It’s in all routing sections available for audio related channels.
The mixer, left hand channel strip, channel edit window or inspector.
And it’s the same for FX and group channels. This allows group to group routing.