GUI not in sync with audio

Apologize if this has already been addressed - not found in search.

ALL of my GUI meters and displays, both native WL and VST plugins, are out of sync with my audio. I see the meters/display move and THEN I hear the audio. I am running 20ms latency on an EMU ASIO soundcard but the delay I’m hearing vs. the display I’m seeing is far greater than that (~300ms).

I am not using any high latency plugins - but even if I was shouldn’t the display be compensated? Is there a control/setting somewhere that corrects this?

PG - I noticed you answered the posts above and below this one. I am on Win7 now so please don’t ignore my WL8 questions anymore. :frowning:

Any ideas why my WL displays are not in sync with the audio? Cubase works perfectly so I don’t think it’s my system or soundcard.

It’s difficult to say why this happens. There is no setting because normally everything is compensated. Espescially for the WaveLab meters (the plugin meters don’t have as much information as WaveLab has, to make the compensation).
Did you try various latency settings? Both for your audio card and also the “buffer number” in the WaveLab VST Audio connections?

I think you should give more info about your system. Especially the graphics part of it, since this is a ‘latency’ between analog audio and visual cues, which is not quite the same as latency in the regular sense, between digital in-the-box audio and analog from-the-speaker audio. Although 300 ms is a very high number in any sense.

Thank you for the reply.

So there is a Wavelab buffer in addition to the sound card buffer? Does the initial install of Wavelab set these buffers to “max”? Otherwise, maybe something changed in my soundcard/ASIO settings.

As I mentioned above, Cubase works perfectly so there is something in my Wavelab setup that is not quite right.

Will investigate and reply back.

I am experiencing this “not in sync” behavior while trying to edit sfx files very tightly.

For example, if I want to edit the extra space before a loud transient, it sounds like I’ve removed the transient even though it is still there. Meaning, you can still see the transient and the playbar passes over it but it sounds like its been cut. Its seems like I have to leave an extra 5-10ms of space before the transient in order to hear all of it.

I’ve reproduced this behavior on 4 files now, so I don’t believe its coincidence. Its a bug. And a bad one that needs fixed asap.

I’m on Mac OSX 10.8.4 with WL 8.0.2. No plugs in use.

OK, I found the problem - it appears Wavelab is not compensating for ASIO sound card latency.

If I set my soundcard latency very low (4-5ms) the meters move in sync with audio. If I raise the soundcard latency to max (100ms) the meters are WAY ahead of the audio. And this delay time seems to be a MULTIPLE of the latency setting - I can see the meters out of sync even at 20ms latency.

Now, I understood Wavelab should be compensating for this. It appears it is not.

BTW - I do not have this problem in Cubase. I can change the soundcard latency to any setting and the meters stay in sync with the audio.

I just tried this same test in WL7 and it doesn’t work right there either - so it must be something in my system - or has been a problem in Wavelab before - or I misunderstood how WL works (no latency compensation?).

As I said, I DO NOT have this issue in Cubase - so what could it be?

One more piece of info I just discovered - it is only the MASTER SECTION meters and plugins that are behind the audio - the TRACK level meters are in perfect sync with the audio!

???

So I just tested on my system and,

With an RME UCX the problem does seem slightly worse when setting the buffer at 512 then at 128. But its marginal. It just always seems to show a few milliseconds of audio in the waveform that I don’t hear.

However,
I switched to using the Thunderbolt Display Built-in speakers and the problem was far worse. I had to have a much bigger section of “header” or blank space at the begining of the file in order to hear all of the file. If I edit the files tight then I don’t hear the transient that I see in the waveform.

So there is definitely a problem with Wavelab because DSP Quattro, Nuendo, PT 10, Audio Finder, Snapper and all the other audio apps I’ve tested are not experiencing this behavior.

I experimented with WL8 some more last night and this problem is TERRIBLE. At one point the meters started moving a FULL SECOND before the audio started. That was with an extreme latency setting but it illustrates the problem.

Not only are the meters out of sync with the audio but it appears their time constants are affected by the soundcard latency as well. The longer the latency the more sluggish the meters.

This is NOT the case in Cubase. The meters always respond like real meters and are spot-on with their timing.

Is there any way I can post a video of my desktop here to show you what I’m talking about?

Well, I get this when I use external (hw) processing, but I was kinda expecting that. So, you don’t have that one enabled, do you? On the other hand, if this is a bug (it’s the same in 7), perhaps something to be looked into?

r,
j,

I was using no external hardware and no plug ins and having the issues I described.

PG- please look into this asap.

Thanks,

It just always seems to show a few milliseconds of audio in the waveform that I don’t hear.

I’'m not sure to understand the problem you mention (and it does not seems to be the same as Fender19, no?).
Can you please explain again in detail, a given case, and maybe add a screen shot?

I can’t understand why no one else besides me and Wavcatcher have noticed this - I have tried WL8 on two different computers and get the same result - the GUI is not in sync with the audio. Something is wrong with the ASIO interface. Cubase does not do this.

Over 400 views of this post - maybe I’m not the only one to notice this issue?

Any comments, PG? Why is the GUI not in sync with the audio - on two different machines?

Plugins can never be fully in sync, because they ignore the latency of the chain. WaveLab meters, should be in sync, however. This being said, translating the driver position to graphics is a complex operation, because of various latencies. Some small differences, up to 50 ms, are common and difficult to avoid. Now, you mention earlier a full second of delay, then I have no hint at all, for the pieces under the control of WaveLab (meters and cursor).

HI PG,

My issue isn’t just the GUI. Its the actual audio output. When I edit a file very tightly for SFX sound design work I am not hearing the entire audio waveform that is shown graphically in the waveform view.

For example, lets say I have a snare drum sample. If I edit the sample very tightly say within 4 ms of the transient “spike” of the hit I don’t hear the hit- just the ring. It sounds almost like the first 5ms or so is faded up.

I’ve repeated this behavior while trying to edit a few samples now. Is there a setting that I can adjust to stop this or is the audio output not actually in sync with the graphic waveform that is displayed in the editor?

I’m using OSX Mountain Lion 10.8.4 with an RME UCX.

Did you try setting this option off:
2013-07-30_19-15-46.png

PG,

Plugins don’t ignore the latency of the chain, they report it to the host (usually) and the HOST is supposed to compensate for it. That’s in the Steinberg VST spec.

So are you saying that Wavelab does NOT have “plugin delay compensation” or compensate for audio latency settings?

How would one ever use this program to record in multitrack mode if that’s the case?

Fender19