GUI with Mix Checker Pro

When I open Mix Checker Pro, plus some plugs from Steinberg Cubase, I get this:
wavelab 31.jpg
I can’t remember what the solution is if there is any?

I’m not sure what it normally should look like but you may have to go into the plugins settings/prefs and disable the GEN checkbox which can give certain plugins a generic GUI which is what this looks like.

Yes! Thank you Justin. I should have known that one, but it slipped my mind somehow. I’m not sure how any got the GEN checkbox in the first place, but that resolves it.

No problem, for reasons unknown I’ve seen this happen maybe a few times in the last 10 years but at least now you know where to find it.