Hairpin length

Most if not all the music I look at has the end of a hairpin centered on the last note it affects which is what I’d like when entering a hairpin. They do NOT end at its notated length. But that’s what Dorico is doing. To me it looks especially strange when it goes over a barline to end just before the next note.
Is there a way to stop this behavior?

Try going to:

Barline interaction -> Stop before

Dorico’s rules for hairpin length follow the rules suggested in Gould’s “Behind Bars”, on pages 103 following (if you have the book available to read it).

Thanks for where to look Daniel. Much appreciated.
Yes I have Elaine’s book. I’ll take a look but there must be a whole lot of publishers ignoring her recommendation about where to end hairpins.

Thanks for where to look Daniel. Much appreciated.
Yes I have Elaine’s book. I’ll take a look but there must be a whole lot of publishers ignoring her recommendation about where to end hairpins.

Yes, I’m sure there are a great many people ignoring her recommendations, and very often with good reasons, no doubt. But I think Elaine’s recommendations make a great deal of sense as a starting point, and in due course we will make it easier to change the rhythmic position of the end of each hairpin in Write mode using the keyboard, and perhaps it will also be possible to introduce different options for the default positions of hairpins, if there are other obvious settings that could be described and implemented.

I would greatly appreciate having a global option to stop the hairpins before the barline. This is costing me a lot of time I’m afraid…

There is indeed such an option: look in the first ‘Advanced Options’ section in the Gradual Dynamics section of the Dynamics page of Engraving Options, and set ‘Hairpins ending at beginning of note at start of bar’ to ‘Do not cross barline’.

Thanks Daniel!

I just wanted to pop in here really quick and say that I too much prefer having the hairpins end at the barline, and really appreciate having this setting available to set as a default!