Hairpins consumes space

Without any hairpins

Adding a hairpin

Trying to shorten it in Write mode

This widens the space even more.

Adding a 2nd hairpin makes the space between notes 1-2 even larger (than in image 2 above)

Is this correct behaviour? It seems odd to me. How can I maintain “Non-hairpin” spacing, with hairpins?


Dorico is working correctly, in that when you shorten a hairpin semantically you are telling Dorico that the hairpin ends somewhere rhythmically before the second note; perhaps on the second 16th/semiquaver of the first eighth/quaver. It needs to be able to show that to the player, and given the setting below it can only make that clear by widening the gap between the first two notes.

The solution is to lower this Engraving Option. It’s in one of the Advanced Options subsections within Engraving Options > Dynamics > Gradual Dynamics.


Many thanks!