Half of my Key Commands won't work.

Okay, I wasn’t surprised when several of my legacy plugs stopped showing up in N6. I kind of expected that. But what I wasn’t expecting was for my Key Commands to stop working in my X-tra Keys keyboard.

Today was my 1st day trying N6 out. I decided to start by programming all of my KC’s and Macros into it before even bothering with trying to mix anything. The QWERTY key commands work. But the same command programmed into SOME of the X-tra Keys buttons do not(?)!

If none of them worked, I would’ve chalked it up to drivers. But lots of them do work. So I’m stumped as to what the problem is. Shift+Page Up from the QWERTY KB will launch the TIME DISPLAY. Shift+Page Up as a one button command from the X-tra Keys KB does nothing. Control+Z will UNDO from the KB, the same one button command from X-keys will not. Yet, I can launch and close N6 from the X-tra Keys KB, what had been the split command on the X-keys now launches the track solo on the hilighted track and my previous Add Audio Track combo command now launches the SAVE PROJECT window. So clearly N6 is “seeing” the X-tra Keys KB.

Anybody else having this problem? Any suggestions on how to correct it? :question:

The only thing that comes to my mind is if Nuendo 6 reacts to incoming key sequences at different timings compared to previous version.

I know that some external programmable devices will allow both a “simultaneous” key press like “control z”, whereas other send them “separately” as a series of key presses where you can set the timing of them going out.

I know in some version of Nuendo I had my Contour shuttle do zoom in / out via key command it it worked perfectly. Then in a later version I did the same and if I ended up clicking with my mouse in the timeline somewhere the tool changed. So clearly there was a problem with the release of the Contour (or “receipt” of Nuendo) not being fast enough before the mouse click.

So perhaps you can investigate timing?

How about if you write down the exact key press series and log them in three categories:

Stuff that does nothing
Stuff that does the right thing
Stuff that does the wrong thing

Perhaps you see a pattern (i.e. all the problems involve the “shift” and “control” keys, but not “alt” or whatever)…

Thanks for your response. X-tra Keys actually comes with a timing selection for just that kind of scenario. I’ll try inserting a delay on some of the commands and see if that has any effect.

Meanwhile, I’d love to hear from any of you using Controllers (Particlarly the Euphonix/Avid MC Pro & Artist’s
MControl)
with N6. How are they working together (or not)? How long does it take to set up? I have become soooo dependent on that X-tra Keys module that, if I can’t get it to work with N6, I may be forced to get the Artist’s MC.
So I’d really like to know if that’s going to help or not.

Well inserting a delay didn’t work. Copy & Paste in X-keys worked with nothing added. But Undo or Duplicate wouldn’t work even with the delay added.

I checked the PI Engineering web site to see if there were any drivers or something that needed to be downloaded to get it to work. But there wasn’t anything. The faq sheet pointed out

PS/2 X-keys
The most common problem we encounter with the PS/2 X-keys is people looking for software to use with it. > The PS/2 X-keys simply records keystrokes from the keyboard. No software is needed. > Instructions for programming your PS/2 X-keys are found on the back (Desktop and Professional models) or in this manual: manxkps2.pdf

If this is the case and Ctrl + C is copy on both the QWERTY KB and X-keys, then why isn’t Ctrl + D duplicate on both? I don’t get this at all. :question:

Yeah, it’s weird.

Have you tried remapping to different keys? After all I suppose there is a chance that a key or row or whatever has malfunctioned (although the timing would be very interesting).

I’m out of ideas.

For a second there, I thought that you might be onto something. I pulled up an open slot on the X-keys and programmed the Ctrl+D command into it. Then I tried it in N6 and it actually duplicated the track! But When I relocated Ctrl+Z in a different slot, it did not Undo the duplicated track (sigh). I tried clearing the original locations (saving the cleared status) and then re-programmed the commands. Still no joy.

Somebody on gearslutz said that they changed something in the preferences section to get their X-keys to work. But I can’t imagine what there would be to change/ This is NOT a MIDI device. It just records key strokes from a QWERTY KB. Do you have any idea what they were referring to?

Are you sure you haven’t activated the “Alternative Key Commands” by mistake?

Fredo

No, I’m not sure. Where are the “Alternative Key Commands?” I’ll go check.

Hadr to say, depends on how much you have changed your Key Commands.
In the early days, it was something with F5 if I recall correctly, and now I think it’s #.
Check the manual to be sure.

Fredo

Thanks for the tip. I saved the Key Commands as a Preset in N4. It shows in the N4 KC Menu INSIDE N4. But when I looked for it in the SB Folder for Nuendo 4, I only found the standard KC Presets that came with N$. Where will I find MY saved key commands? I can’t import them into N6 without knowing which folder to point to.

I just opened the folder IN N4 to access the KC’s from the front end. All of the presets listed in the submenu are.XML not .KEY or .MAC. Even the factory presets didn’t show up in the folder. Is there a way to export the saved preset I just made, in order to load it into the N4 folder? Then, I could import it into N6.

I just did a search of my C drive to find the N4 KC Preset. It pointed me to C:\Users\Owner\AppData\Roaming\Steinberg\Nuendo 4|Presets Note there is no mention of the KC Folder. So it SHOULD BE IN THE PRESETS FOLDER. There are several folders and several .XML files but none of them is the KC Preset I saved. When you open the KC folder located in the presets folder, you find the factory .XML preset files, but, again, NOT the one I saved inside of N4.

Meanwhile, the manual says that I need a .KEY file anyway. So how do I get my preset to save as a .Key file?

From the N4 Manual:

Saving complete key commands settings as
presets
As mentioned above, any changes made to the key commands
(and macros) are automatically stored as a Nuendo
preference. However, it is also possible to store key commands
settings separately. This way, you can store any
number of different key command settings, complete or
partial, as presets for instant recall.
Proceed as follows:

  1. Set up the key commands and macros to your liking.
    When setting up key commands, remember to click “Assign” to make the
    changes.
  2. Make sure that “Store Selected Items Only” is not activated.
    This option is for saving partial key commands settings only (see below).
  3. Click the Save button next to the Presets pop-up
    menu.
    A dialog appears, allowing you to type in a name for the preset.
  4. Click OK to save the preset.
    Your saved key commands settings will now be available in the Preset
    pop-up menu for your future projects.

The instructions are the same in the N6 manual. But there’s no mention of how to save them as .Key files ro from where to retrieve them when you want to import them into later iterations.

I had a similar issue; this is how I fixed it:

https://www.steinberg.net/forum/viewtopic.php?f=177&t=36219

Chewy

Okay, so how do I access the file to change it from “.XML” to “.key?” I can’t find anything in the properties section that will allow me to change the suffix.

This makes no sense. If we’re supposed to be importing and backing up these presets as “.key” files, then why are the factory presets stored as “.XML” files in the first place?

This has been a Great Mystery of Nuendo since at least v4. I forget if it precedes that. But, you’re absolutely right: it makes no sense at all.

And, in previous versions, when bringing my scoring sessions over to a studio’s Nuendo setup (Me on Mac at my place; PC at the scoring studio) I was NEVER able to transfer the key commands I’d saved to a thumb drive.

I think it’s a lost little back eddy of unfixed bugginess and/or bad technical writing in the manual.

Unless we’re doing something wrong, and somebody else has been able to work as described. Haven’t heard that from anybody, though…

Chewy

I’m sorry-- that, I can’t help you with. They changed without issue on my Mac. Haven’t tried doing it on a PC.

Chewy

Okay, forget importing the KC’s from N4. WHY can’t I just build the KC’s from scratch using X-Keys? That’s what I really don’t understand. If the commands work from the QWERTY KB and the X-Keys recorded the exact same KC’s in the exact same format AND N6 is clearly “talking” to the X-Keys, WHY won’t it just accept and follow the same commands???

This is ridiculous!

I GOT IT! There’s an entirely new layer in X-keys that got added when I installed N6. I found it when I realized that I could now scroll down a longer list that had developed. Previously there were only 3 items on the list: Global, Nuendo 4 and Red. Once I found the Nuendo 6 option, I found that all of the previously non working commands were now in empty boxes! Once I copied the commands into those boxes, the commands started working!

Mystery finally and mercifully solved!