halion 3 track not included in mixdown

Hey all,
yet another mystery.I got this project with 6 audio tracks and 2 halion3 piano tracks. The piano tracks play back fine. Each time I do a mixdown, the first piano note is there and then …it disappears. Everything else is fine, but halion is NOT in the mix. :open_mouth:
I reloaded it, recreated a track, soloed it etc etc…it just won’t happen. All is routed correctly to the main stereo outs etc.
the weird thing is, when I do a real time mixdown it’s all there. I’ve never seen this before - does anyone have an idea what the reason could be??

Did you try Realtime Export? How about recording to an audio track via flexible routing?

hey mashedmitten

yes I ended up using real time export, which , strangely, worked fine. it´s just that the track is simply omitted in an export mixdown. :confused:

anyone? :confused:

Instrument track or VSTi channel…?

Not sure what you mean thinkingcap. It’s on a normal midi track that links to its usual vsti track. Both are normally open and play fine. On the exported file, the first piano note is there and then the piano is gone. all there in the realtime export.
In this tune, I have halion 3 loaded with the wizoo acoustic piano and one instance of Spector . Spector is fine in the export. I’ve tried loading different instruments into halion 3, same thing - they’re not in the mixdown.
Totally bizarre… looks more like some sort of bug to me.

Well, that´s what I meant: Do you use an instrument track, or aMIDI track and the instrument rack. So the instrument rack and VSTi channel rules out my possible explanation.

sorry thinkingcap you lost me there…I may be missing something here, still not sure what the distinction is …how can I have a midi track for a vsti without the corresponding instrument track, or vice versa?

Some VSTi’s require Realtime Mixdown due to latency of the individual VSTi. Plenty of examples on the forum. If Realtime worked, don’t worry.

There is a difference between “Instrument track” and “instrument channel+VSTi rack+MIDI track”. Nevermind, it´s probably as mashedmitten says.

sorry Thinkingcap, I had a brain jam of sorts…now I know what you meant, hadn’t clicked right away… :blush:
Actually, when I create an instrument track and put the piano part directly on that…guess what , it’s in the mix.

mashedmitten, thanks for the reply, but if I’m not mistaken, an export mixdown has nothing to do with latency, as the file is simply calculated,which is a different process altogether, and not played back via asio drivers. therefore, I don’t think the latency issue applies here. Anyway, I don’t know why it didn’t work with the midi track, but it does now.
thanks guys.

Today I ran into this problem, I have 1 HALion instance loaded into 1 channel and use several midi tracks for intruments inside this HALion instance.
It plays back fine, but is not in the mixdown (tried realtime and this check box “external midi”, nothing works).

Does anyone know how to get this working?
(I am using Cubase 8.5 on a Mac with El Capitan)