Halion 4 envelope doesn't seem to work!

Hi everyone,

Halion 4 and me don’t really get on.

I’ve imported a harp preset (.fxp) file which worked fine with earlier versions, now can’t make the envelope fade out gracefully when I release the note. This is kinda basic stuff and I’m more than a little frustrated at spending an entire morning on it with no result. Is there some hidden mode that is telling it to just ignore the envelope control???

If I hold the key down the sample plays to end, fine. If I release the note before sample end it begins to tail off then stops with a click. (See screenshot, I’m just playing the selected sample, f#3 though a similar problem afflicts all the zones.)

I must say I think this program is ridiculously over-complicated and unintuituve. I don’t want a 64 node envelope with programmable curves on each phase, just an ADSR that works. But any help would be very much appreciated!
halion_sshot.jpg

Have you tried unchecking the Halion 3 compatibility mode? blue icon, with 3 inside

Try dragging that last node a bit longer. In sustain mode the envelope is at sustain for as long as you hold the note. When you release the note it goes to the stages after the sustain.

Tried that. No effect sadly. Thanks anyway.

That doesn’t behave as you’d expect. If I drag the final node to, say, 1 sec, then when I release the note it carries on for 1 second, but still ends abruptly with a click rather than fading out. It’s as though the release level is set to 100% rather than 0%

Solved (not very satisfactorily) by re-importing all the samples and manually re-creating the preset. Hope I’m not expected to do that with the other 10 Gb or so of Halion stuff