Halion 4 - Loops stop for no reason

Hi there. I’m new here and I don’t know if this has already been discussed.
I use H4 to play loops, and sometimes (randomly) they stop playing before the loop ends.
I’ve tried to use different interfaces/ASIO drivers, multiple midi keyboards, and have all the updates installed, still it happens.

I run H4 on Cubase 5.5
Windows 7 64bit
PC: ACER aspire 5741
Intel core i3-350M (2.26GHz, 3Mb L3 cache)
4Gb Ram DDR3
250Gb HDD

Could anybody help out with this?

Thanks in advance

No one has this problem???
Please, I have a gig in a couple of days and I cant seem to fix this…

Could you save a preset with that problem and share it with us? So we can check.

I had problems of loops not looping, due to incorrect sample end or loop end values, but I don’t know if it’s your case.

Strangely, in Halion 4 you can specify an end of sample value bigger than the sample itself, and the same about the loop end value. This if done by error could cause not sounding sounds upon reloading the preset.

IMHO this could also be a potential cause of memory corruption and crash.

Thanks a lot!
How do I post a file here?
But it happens even with mixed programs (H4’s Glockenspiel with some extra samples)

here you go!

http://dl.dropbox.com/u/6081389/Programs.zip http://dl.dropbox.com/u/6081389/Programs.zip

Thanks in advance :slight_smile:

You have to export the programs with the samples.

From the Program window, select the root object and press the left mouse button. Select “import/export” then “export program as vst3 preset with samples”.

That should do it!

Anyway, did you check if loop end values for the samples are valid?

Here you go:

As for the loop end values, I didn’t, but these are all “drag and droped” wav files, and most of the time they play all the way through, so there should be no problem there.

It just seems that they recieve a Note off command when there is none…
I already tried with M-Audio fast track pro, and fast track Usb. Also used an old roland midi keyboard vs a keyrig usb midi keyboard, both with and without a sustain pedal, just in case…

Also I uninstalled a vst called uHe Tyrell (free vst synth)… but haven’t tested it yet…

Ah, I see they are not looped, but one shot samples. I couldn’t find anything strange on the programs or the waveforms.

Try playing until it happens again, and check if always happens at the same samples and in the same time. Then the problem could be in the sample itself.

It’s not.

It’s really random. It happens in any sample, at5 any time, and in any program…

I even tried taking out a recent 2Gb RAM dimm to see if there was any kind of conflict, but it just happened again…
I’m getting really nuts about this!!!

Can you try in another computer?

Not really.

But my desktop PC, with Win XP-32Bit didn’t seem to do this…

Hi there.
After a lot of attepts I can’t seem to fix this.
I keep having dropouts after the preloaded parts of the loops.
Is there a way to increase the amount of RAM preload??



Check the Options-Menu. Should be called stream or something…
Maybe you don’t have enough voices set.

I’ll check the Glockenspiel-Program tomorrow and check it out.
Maybe I can find something ('though I’m using Mac OS X).

We’ll see.

Can you try without (turn off) streaming/preload? I have never played with the streaming parameters myself (never had any need to do so) so I am not sure if this is even possible. I do recall seeing something about it somewhere in HALion, but I don’t remember where, sorry.

Since this is the first I even read about this, I would presume that is not a HALion 4 issue. I could of course be wrong.

It is possible. :wink:

I mean you cannot really turn it off.
But you can switch between ram and disk streaming.
The default setting is 50/50.

And even if you choose to stream everything from disk
Halion still has to load the attack phase of the samples into the ram.

I thought more of getting rid of various stress factors in the streaming process and possibly locate what is causing the interruptive behavior.

I take it your system has sufficient resources, even when everything is loaded? (CPU, RAM, decently speedy drives, etc.)


I cannot download the program from your dropbox anymore to check.
But as I read here, it’s said that the playback-mode is “One Shot”.
One Shot does not allow to loop material in any way. You have to set
the playback mode to normal, then go to the sample editor and define
a sustain or release loop (when you want to repeat the whole sample just
leave the loop markers at the start and end).

But I guess this is not the problem… It’s just that it sounds strange when
the topic is called that a loop stops for no reason, when I read that the samples
are played in One Shot-Mode.

I see. That’s also a part of the options menu (Max CPU, Disk/RAM Balance, Max Preload plus you see e.g. the used and the available memory, so it’s the right menu to check that out and take further settings).

I just looped a sample in H4 and everything works fine. No problems here.
Can you upload the program one more time? I’d really like to have a look at it.

Best regards.

Hi there.
You’re right.
They’re not loops, just one shots, sorry. What happens is that sometimes some samples stop, apparently after the preloaded part.
I’ve set it to 100%ram/ 0% CPU but still no improvement.
here are a couple of programs…

Could this be because I’m using all 16 midi channels??
My cpu/ram meter doesnt go past 50% so I suppose it’s not a PC issue.
Last year I was using Sx2 with H2 (cracked versions) before I bought C5 and H4 and everything was ok…

Thanks for caring :slight_smile: