HALion 5.1.10 update available

The HALion 5.1.10 update is now available. The update fixes the installation issue on windows as well as the MegaTrig issue.

The update can be downloaded on the support pages:

Thanks MQ,

Just updated!



Definitely executing this update from your desktop is the way to go. I would only get errors from attempting to install from my Downloads folder.

Very well done for the quick turn round.

PS - It would also be nice if this slightly irritating bug was also given a once over at some point … at has been two years since reported …

But why is the Win update file 575 MB big??! H5.1 update was 93MB, and even the original H5.0 installer only has 268MB.

I am still not able to install the 5.1.1 update using either the install.exe method or directly using the .msi file (win 7 64 bit). Install.exe just stops working. Using the .msi file I get the message "already installed . . . ". I am looking forward to curing some issues with HAL5 in (plugin - Cubase 8). I have tried some of the workarounds that were in the 5.1 thread, but to no avail. Please advise.

Update - Feb 15 - I just installed the 5.1.1 update on a different machine running Win 8.1 64 bit and had no problem. Upgrading from Cubase 7.5 to Cubase 8 (when CB8 was first released) also exhibited the same problems, although I was able to use the .msi file to install the Cubase 8 update.

I am hoping to hear some progress on the issue with Halion 5.1.1. THanks.


I’ve downloaded the latest update for Halion 5

Cant seem to register the software…I opened the e licenser file already…
The stand alone version crashes, and also says there a missing sound archive.

Found this quite frustrating, any help appreciated thanks

scrap that, sorted now… cheers

Thank you Matthias.

It works flawlessly.


After ten attempts of upgrading and it crashing, once I choose 64 bit. I came to this forum.
Moved the installer to the desktop and it installed.
Why it can’t install from another directory escapes me.

I bought Absolute 2 two weeks ago. Halion 5 says it is version So I thought the 5.1.10 update is needed.
Anyway, when I try to install the update, the installer says already installed- no changes.
I’m on Win 7. What should I do?

I have the same. I re-installed to make sure.
I think by 5.1.10 they mean The announcement is dated Feb 2015 and v5.1.1.60 is dated Jan 2015.

Am I right?

Can anyone help me with this please.
i purchased & installed the Absolute 2 bundle, however all the vsts showed up in the plug ins browser except Halion 5, i’m using Ableton 9.5 (64bit) i’ve tried everything, the stand alone version opens & works fine. its in ableton it won’t show up
Halion 5 is also 64 bit, all the others work fine except that 1, im at a lost
help please

Im having the same problem. I’ll give the desktop workaround a try.