Halion 5 Crash when loading presets


I’ve spent several days now reading and trying everything I can to fix this, but I’ve run out of ideas and hoped someone on here might be able to help.

Halion 5, both stand alone and in Cubase 7, keeps crashing after loading a few presets. It only happens when loading Halion Factory content, all other presets such as B-Box, Trium, Halion Sonic Content etc work fine as far as I can tell. It seems to happen particularly after clearing all rack slots. I’ve tried all suggestion I’ve read over the past couple of days including a full reinstall of Halion, disable anti-virus, launching Halion with administrator privileges and using different audio hardware and nothing seems to work.

Not sure if it matters but there is also a little red warning triangle next to the output selector in the rack list which is only there when Halion Content is loaded. If anyone can also tell me what this means I’d be grateful as there is no hover over hint for it.

Here is the text from the log file for the most recent crash log.

HALion 5.exe 2.2.5 Build 18 - 2.12.2013 19:25

Timestamp is 51c40a9b (Fri Jun 21 09:11:07 2013)
C:\Program Files\Steinberg\HALion 5\HALion 5.exe

Exception code: C0000005 ACCESS_VIOLATION
Fault address: 0797549E 01:00A3449E C:\Program Files\Common Files\VST3\Steinberg\HALion 5\HALion 5.vst3Bytes at CS:EIP:
4e 8b 54 02 10 49 ff c1 4e 89 14 02 4e 8b 5c 02
18 4e 89 5c 02 08 48 83 c2 10 4c 3b c8 72 e1 eb

I’m running Windows 7 64bit. Intel i7 4770 processor, 16GB of RAM and using Steinberg UR22 audio interface.

If anybody has any more ideas please let me know.


If you load Halion Sonic 2 and pull up the same patch, do you get the same crash? Also, so I can test here, let’s pick one specific patch to test with. What patch is crashing for you?

Thanks for getting back to me.

First off, this is only happening with the HALion Factory patches which don’t appear in HALion Sonic 2. Should this be the case or should I be seeing them. Anyway that means I can’t test the same preset in HALion Sonic.

Unfortunately I cannot give you a definitive patch that makes it crash. It seems random which makes this all the more puzzling. I’m a computer programmer myself so quite enjoy the challenge of nailing down bug :slight_smile:

I seem to be able to guarantee a crash be following these steps.

  1. Click “Show Empty Slots”, then click “Remove All Programs”.
  2. Load these patches in the required slots:
    Slot 1 - 4.0 Aah Choir
    Slot 2 - 4.0 Filmscore Strings
    Slot 3 - 4.0 Mmm Choir
    Slot 4 - 4.0 Ooh Choir
    Slot 5 - 4.0 FM E-Piano 3

Then it crashed.

This is not consistent though it can be after loading anything between 2 and 10 patches before it crashes but like I say only the HALion Factory content is affected.

Also I am still wondering about the little red warning triangle as this is only appearing on HALion Content. As you can see from the attached screen shot it is not next to MODEL C or HALion Sonic patches.

I know this is most likely something to do with my system or my installation but I am really out of ideas.


The Red Arrow refers to the track having outputs that are not properly connected to live outputs from Halion 5. This is occurring with the 4.0 content because it is surround content and you (most likely) have not setup multiple outputs from H5.

Mine crashed when I got to loading the FM E-Piano 3, I will forward this to our developers and see if they have any feedback on the issue.

Thanks for the quick reply even though I was totally surprised to find you hit the same issue. I’ve messed about a bit more and it does only seem to be the 4.0 or 5.1 content that causes the crashes, every other preset seems to be fine.

I’m guessing it may have something to do with the missing outputs. When I get some time I will connect an interface with 5.1 (I’ll have terrible latency but it will prove a point) and see if I still get the same problem.

Was this issue addressed? I’m having the same issue. I haven’t tried assigning all the outputs to my interface outs. I’ll try that shortly and see if it solves my issue. My concern here is … what do you do if your interface only has 2 outs like the UR22?


There has not been an update to Halion 5 yet. Are you getting the crashing also? What operating system are you on? What version of Cubase are you using Halion 5 in?

Personally, I would not suggest using the 4.0 or 5.1 patches if you are not connecting to similar outputs.

I was just about to report the same issue too, with video. If you change between 4.0 string-section instruments while notes are being held, the program will crash at some point. It’s 100% reproducible both in VST and standalone format.

I get the same issue.

After some patch changing (in the first slot, no other slots), the standalone version and the AU version crash. After restarting I can load the same patch without any problem. After some patch changing … crash again.
All other software works perfectly, so this is not the system’s problem.

iMac 12.1, 32GB RAM, 500GB SSD, Mavericks 10.9.4 fresh install, Logic Pro X 10.0.7.