Halion 6 and Groove agent 4 with Logic Pro x

Folks,

Halion 6 and Groove agent 4 now stop working Logic Pro x. The stand alone works but not the AU. they both work in Cubase 10. I downloaded the latest everything but no luck…what am I missing?

Halion 6.3.0.72 works for me in Logic Pro X 10.4.6. Don’t know how well, but I can open it just fine and play chords and what have you.

Thanks for the response Zipb. below is what I’m getting when I try grove agent and I’ve tried everything with no luck.

validating Audio Unit Groove Agent by Steinberg:

AU Validation Tool
Version: 1.6.1a1
Copyright 2003-2013, Apple Inc. All Rights Reserved.
Specify -h (-help) for command options


VALIDATING AUDIO UNIT: ‘aumu’ - ‘sga4’ - ‘Stbg’

Manufacturer String: Steinberg
AudioUnit Name: Groove Agent
Component Version: 4.2.50 (0x40232)

    • PASS

TESTING OPEN TIMES:
COLD:

===============================================
– eLicenser License Control Error –
Could not launch Synsopos server application!

error: -1701

In case this problem persists, you might want
to try one of the following before contacting
your software vendor’s support department:

  • Manually quit the “Synsopos” process
  • Restart your computer
  • Download and install the latest version of
    the eLicenser License Control software
    from http://www.eLicenser.net
    ===============================================

2019-09-16 19:51:02.693 auvaltool[777:11352] apply_selection_policy_once: prefer use of removable GPUs (via (null):GPUSelectionPolicy->preferRemovable)
Time to open AudioUnit: 18768.980 ms
WARM:
Time to open AudioUnit: 0.111 ms
FIRST TIME:
FATAL ERROR: Initialize: result: -1


HERE’S THE CRASH THREAD…



Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x00007fff720362c6 __pthread_kill + 10
1 libsystem_pthread.dylib 0x00007fff720f1bf1 pthread_kill + 284
2 libsystem_c.dylib 0x00007fff71fa06a6 abort + 127
3 libsystem_malloc.dylib 0x00007fff720af077 malloc_vreport + 545
4 libsystem_malloc.dylib 0x00007fff720aee38 malloc_report + 151
5 com.steinberg.HALionSonic 0x00000001108cf981 0x10fbdb000 + 13584769
6 com.steinberg.HALionSonic 0x00000001107ea5d7 0x10fbdb000 + 12645847
7 com.steinberg.HALionSonic 0x00000001108d41a7 0x10fbdb000 + 13603239
8 com.steinberg.HALionSonic 0x00000001107e3ece 0x10fbdb000 + 12619470
9 com.steinberg.HALionSonic 0x00000001107e1996 0x10fbdb000 + 12609942
10 com.steinberg.HALionSonic 0x00000001116037d5 0x10fbdb000 + 27428821
11 com.steinberg.HALionSonic 0x00000001117d8f3d 0x10fbdb000 + 29351741
12 com.steinberg.HALionSonic 0x00000001114128d2 0x10fbdb000 + 25393362
13 com.steinberg.HALionSonic 0x000000011141221e 0x10fbdb000 + 25391646
14 com.steinberg.HALionSonic 0x00000001117df915 0x10fbdb000 + 29378837
15 com.steinberg.HALionSonic 0x00000001117df76c 0x10fbdb000 + 29378412
16 libsystem_c.dylib 0x00007fff71fa13cf __cxa_finalize_ranges + 319
17 libsystem_c.dylib 0x00007fff71fa16b3 exit + 55
18 auvaltool 0x000000010beca71c 0x10beba000 + 67356
19 auvaltool 0x000000010bebd837 0x10beba000 + 14391
20 auvaltool 0x000000010bebd119 0x10beba000 + 12569
21 auvaltool 0x000000010beca022 0x10beba000 + 65570
22 auvaltool 0x000000010bebc04a 0x10beba000 + 8266
23 auvaltool 0x000000010bebb27d 0x10beba000 + 4733
24 libdyld.dylib 0x00007fff71efb3d5 start + 1

Upgrade elicenser software? Shot in the dark, synopsos is copy protection, I think.

https://helpcenter.steinberg.de/hc/en-us/articles/360001406039-macOS-10-14-Mojave-Steinberg-program-wants-access-to-control-Synsopos-app

Thanks Timo…that did not resolve the issue… I submitted a ticket to support.

Timo, I just got it fixed. There was a line in the automation section in Mojave that had Logic Pro and under that there was a check box for the Synsopos. Once I checked that box it all started working. Thanks for the info.