Halion 7 Crashing Cubase 12 Pro Consistently

Long time Cubase user here (since SX3) and recently upgraded from 11 pro to 12 pro. Since upgrading, everything is working fine except Halion SE 7. Certain content sets will crash Cubase as soon as a note is played (the programs will load fine and instrument-specific controls appear but will then crash when playing any note). This happens with Halion Sonic 7 standalone app as well. This isn’t a random thing - it is repeatable every time. The factory HSS sets all load and play fine along with Hypnotic Dance, but others such as Verve, Novel Piano, and others I have been using successfully for years are now crashing every time. Anybody else experience something similar to this? Could it be a compatibility issue with some content sets or perhaps a bug?

I tried reaching out to support, but they refused to look into the matter since I am on a non-Ryzen chip still, but other than that the rest of my system resources are fine. Running W10 with an RME UFX+ interface. Again, zero issues over the years including a long stint on this same PC with Cubase 11 Pro.

Debug files include the following clues:
ERROR_CODE: (NTSTATUS) 0xc000001d - {EXCEPTION} Illegal Instruction An attempt was made to execute an illegal instruction.
00000000`41ad3db8 660f3a08c201 roundps xmm0,xmm2,1

Also, immediately after Halion crashes, if I try to relaunch Cubase I get a VSTConnect error (“Process with the ID NOT found”) followed by license errors that basically show no licenses were found for any of my VSTs across the board. I need to do a full reboot to recover from this. Once rebooted, everything opens and loads fine as long as I don’t launch those certain Halion SE 7 content sets.

No other VST on my system is having an issue including all third party VSTs from iZotope, reFX, etc. Halion SE 7 is literally the only thing not working correctly. And yes, I have tried reinstalling everything with no change.

Apologies in advance if this should be posted in the virtual instruments category instead of Cubase.

What does this mean? Are you saying your CPU isn’t supported? What is it?

Have you made sure you a running the latest versions of content and plugins?

By the way, the product name has been changed – it’s Halion 7 or Halion Sonic 7.

Support says only Ryzen AMD chips are now supported, and that it was the same for Cubase 11 Pro as well, which I had been running with absolutely zero issues on this same system. I am still running an AMD 6-core from before Ryzen was out. W10 Pro 64-bit, 32GB, etc. This issue is strictly limited to certain content sets within Halion 7. No issues with any other VST or overall performance/latency. The factory sets all load and play fine. And yes, everything is up to date including RME drivers, VSTs, and even Windows.

And thanks for clarifying the current naming convention. Updated title.

It sounds as though HALion (Sonic) 7 and/or Cubase 12 is trying to execute a CPU instruction that your non-Ryzen AMD CPU simply doesn’t have, hence why you got an ‘illegal instruction’ error, and this is almost certainly why they say only Ryzen-era CPUs are supported now.

I finally got around to updating my system to a new AM5 7950X platform and have had zero issues with Halion on the new system. It was just strange that only Halion 7 and certain content sets within it would cause the crashes with my old workstation while every other Cubase feature and VST worked fine in C12 using the older, non-Ryzen CPU.