Halion 7 VST not shown in Studio one 6 - where is the is the VST path?

Hi all,

I installed the Halion 7 software with Steinberg Product Manager.
Unfortunately the appication itself makes no sound while the keyboard is sending midi input and in Studio One 6 I also don´t see the VST for Halion 7. Only Halion 6 is in the list - even after running an update vsts in the browser.

Any ideas to these 2 issues?

After the download of the software I found the steinberg product manager showing “reinstall software” which I did not want. It suggested to me it did install the software all by its own. My assumption is, that everything necessary was done by the SDM.
Also I can run the Halion 7 software in standalone mode as already mentioned. No sounds though… :frowning:
Please advice!


If you haven’t rebooted your system after upgrading to HALion 7, I suggest you do that first.

I’m pretty sure HALion 7 does not support VST2, in line with Steinberg’s VST2 deprecation policy. You don’t need to specify a path for VST3, as it is always the same and not user-configurable according to the VST3 specification. I don’t use Studio One, but can you double-check that HALion 7 is not showing as a VST3?

Your output issue could be down to the output set in the settings dialog of HALion standalone. Are you on Windows or Mac?

Sounds have are now working in the standalone app of Halion 7.
But Studio One still does not find the Halion 7 VST for some reason maybe also not Halion 6.
Halion 6 is shown in the vst list of S1 but does not produce a visualization ones dragged into the Studio One workspace onto a track. Halion Sonic works as expected.
Halion 7 is even not represented after a full vst scan in S1.

Any more ideas?


HALion 7 should replace HALion 6 if installed correctly. The two cannot co-exist.

I would uninstall HALion and reinstall it, then reboot and try Studio One again.

1 Like

Hi @Stevie_Simon ,

sorry to hear that you run into trouble. S1 is usually a very good vst3 host, so HALion 7 should work. Before sending you to Presonus or Steinberg support, we can try a few steps for due diligence troubleshooting.
You are right in your expectation that the Steinberg Download Assistant should have handled everything correctly. To be “closer” to the system, I would like to ask you to run the downloaded installer directly.
You can access the download folder with the following steps on the screenshot below:

If there are any errors during the installation or if S1 can still not find the instrument, please let me know.

Please also try uninstall and then install again if “reinstall” option does not work. Thanks.

You haven’t accidentally hidden it in Studio One have you? Open up the Plug-In Manager:

Then search for HALion, and check that it’s not been hidden (You want a white dot, you can see i’ve hidden Audio Unit versions on mine):

No Halion 7 visible, nor blocked/disabled.

If Halion 6 and Halion Sonic 3 are still present on your system, then either you didn’t install Halion 7 and Halion Sonic 7, or the installation failed. Please follow the instructions provided by Philippe above:
Halion 7 VST not shown in Studio one 6 - where is the is the VST path? - #5 by Philippe_Bono

Hello all,

I deinstalled Halion 7, and reinstalled it 2 times. Reinstalling it ones from SDM and another time via the downloaded installer, rebootet and still no Halion 7 in S1.
I checked Cubase for the plugin an there it was.
Cubase ok, S1 not.

Any more ideas?


Check your drive to see where the HALion 7 plugins are perhaps? And then check that Studio One has the location registered too:

There’s not much else that can be wrong, really… It’s really strange that you still have HALion 6 showing after installing 7 though.

I found the VST3 and it´s already in my search path like in you screenshot ski.


Wow that’s got me stumped lol. Had to resort to a google search, have you tried the “Remove Plug-In Settings” as discussed in this thread? :

Seems that resetting and rescanning on it’s own aren’t enough with S1 sometimes. Just wonder as H7 will replace H6 if it’s got a bit confused somehow?

1 Like

Infact resetting the blocklist and scanning on start-up did the trick.
Rescanning the plugins from the plugin manager did not.
Also I reset the blocklist in the plugin manager and rescanned the plugins. That did not work.
It needed to be in the options dialog apparently. Strange.

Thanks all!