Halion/Iconica. How to control dynamics with expression ctrl to make sound disappear completely but gradually.

Hi everyone! I have a problem with dynamics in Iconica Sections & Players/Halion 6. The sound doesn’t go away completely and keeps playing while a note/key is depressed even when I move expression controller(mod wheel) to the lowest position. Same issue happens with some other products for Halion, HSO for example.So, how to control dynamics with expression ctrl to make sound disappear completely but gradually?Here are two demos as a comparison/demonstration of how it works in Iconica and what I would like it to be: Iconica and Not Iconica

Note: Also, dynamics Bar/indicator for dynamics in Iconica shows ‘p’ and not ‘ppp’ as it’s shown in manual to the product screenshot. So it seems there should be a way to achieve what I need. But how? Please, help.

Did You tried to set up Release parameter? Im not sure ifI correctly understands Your issue, but I think that it should solve it.

Hi! Thanks for your reply! I’ve tried changing release parameter but it seems it’s not what I need.

I need something like this:

  • I press and hold a key on my midi keyboard
  • Sound starts playing
  • I move expression controller (modulation wheel) down
  • Sound disappearing as I move mod wheel
  • Once mod wheel is at its lowest position sound stops completely
  • I release a key of midi keyboard

I could solve this by assigning volume/level knob to mod wheel, but in this case sound changes too rough and it feels not natural.
Besides it doesn’t change dynamics from piano to forte it’s just changing volume.

I still hope there is a way to achieve what i need with mod wheel. It requires more experience and deeper exploration of Halion 6/Cubase.

Ok what about this. Use modulation wheel as dynamic controller ( settings inside Iconica macro page under steinberg logo) Then Velocity mapping of sound is linked to mod wheel ( typical for sustain programs) Then assign volume of program automation to mod wheel but carefuly set min and max for this automation ( I didnt find how to set curve for this automation, it would be better) so set minimum value about -25dB should be enough for silence already low velocity sounds. if not, add to bus after fader some gate with longer release to more natural feel.

Result should be silencing as You wish, and use of velocity maping to achieve more realistic sound. -25dB works for me in case of Cello program.

Another way. Map dynamic range as I said, and also carefully set gate to silence low velocity sounds. it works also pretty nice. ( Idea is that volume at lowest dynamic range is always under gate threshold value. Than only attack and release has to be set for natural sounding and modwheel shall works as You wish) Problem could be between single note and heavy chords - because they will have different velocities. Then I would recommend my first proposal which also controls overall volume.