HALion instrument levels really low

I’ve just created a default “Piano and Voice” project. Vocals are working well, and midi keyboard is playing through Cubase with the default piano sound, but the sound levels for the piano are really low. The sounds levels are all the default zero, on the inspector, and in the Mix console. However, the sound level meters show the piano peaking at -20, and that’s hitting the keys fairly hard. I can push the levels up everywhere, but really, with all the sliders at zero, it should be louder than this, and more comparable to the voice. I don’t think it’s the MIDI keyboard, because I’ve been using it with Garageband no problems, and in Cubase, the little “Midi IN sound level meter” in the bottom right corner of the screen is indicating plenty of volume.

It’s not just the piano sound, as I’ve tried a few other HALion instruments, and they are also really soft.

What do I need to do to get proper levels from the instruments?


The Piano + Vocal project template is using HALion Sonic SE for the piano. Double check the Volume of the MIDI Notes, please.

The „MIDI in sound level meter“ is no sound level meter, and does not indicate volume.


Meters of the Instrument tracks show the Audio Return signal, so actually it does show a real velocity.

For my ‘Normal’ playing, the MIDI velocity is around 50-60, and for individual notes the mix console meter shows around -20. If I hit a key really hard, I can get the MIDI velocity over 100, and the mix console can show -5, and if I belt out a few chords, the mix console meters are nearly reaching 0.

Everything is on a new install of Cubase, and default project settings. I just don’t know why it’s all so soft.

Is this normal, and I just have to crank it up on every project?


Myself, I would say that Velocity 50-60 is mp dynamics. It’s slightly below 50% Is this what you want play/achieve?

If you draw a MIDI note by using Pencil tool, the default velocity is 100.

I would recommend to investigate on the keyboard if there is something like Velocity curves.

Yes, I’m probably playing around mp to mf. Would you consider -20db to be mp? It sounds more like pp to me.

-20 dB is - if at all comparable with an instrument dynamic expression - rather louder than pp.
If you can reach 0 dB Fs, the Instrument levels in Halion are just where they should be, and you should check the velocity settings or curves of your keyboard.
Apart from that you also have the possibility to add a MIDI offset in Cubase which will raise all your played velocities by a desired amount.

Found part of the problem…

The piano part in this default project has a compressor turned on. Turning off the compressor helps to get some dynamics back into the channel, and get is sounding louder. It’s still low, but it certainly helps. As far as I can see, the main stereo out doesn’t have a compressor on it. Maybe it’s just a soft piano, as some of the other instruments seem a little louder.

Still have to mix the piano right up (slider at the top, +6) to be where I’m used to.


If you have been using Piano + Vocal factory template, Piano doesn’t contain Compressor effect. There is VSTDynamics plug-in (which contains Compressor) on the Vocals track applied.

I really don’t know what’s going on. You are right, I created a new project from the same template, and the compressor was not on. Levels are still lower than what I’m used to, but it sounds like that’s where they are meant to be, so I’ll just live with it. Thanks for your great help.