Halion not registering channels

I’ve been messing around with this for about 9 hours straight and I can’t get ANY channel to work other than the 1st channel on Halion. If I want to record more than one track I have to open a NEW Halion vst when there are 16 outputs but they do not register for some reason. This is very frustrating. I’ve looked at vidoes but no help. All I want is for all 16 channels to work I don’t understand why this is so hard to get done. It’s a college course to learn basic UI elements that should have been incorporated into this program years ago and it’s really frustrating. I’ve wasted so much time just trying to do simple things when my album should have been done already. I can’t even think straight anymore because HALION only registers ONE track and I’ve tried everything. There are 16 possible tracks on HALion, and when I select an instrument on the 2nd track, and on HALion, it only plays the MAIN output. I’ve already changed all outputs manually in HALion and it still isn’t working. Please help. Here’s a pic of my Halion not working like it should.

Just let me know if Cubase is bugged or if the interface isn’t supposed to hold 16 TRACKS like it says on the HALion screen.



Do you mean Audio Returns, right? Not MIDI Channels.

Once you route the signal to the another Out in HALion (what you did already, if I understand), you have to enable the Output also in Cubase. Open Track name tab in the Inspector of Project window, and click to the Instrument Outputs (looks like this: [-> ). The list of Audio Returns from HALion appears. Enable the output(s) you want to use.

OK, now I see your screenshot. :slight_smile: So this is already done.

Did you route it in HALion Sonic SE (Mixer page)?

Make sure that your channels are not all on “channel 1,”…this can happen when using Track Instruments. If so, change the Midi Channel’s accordingly: 1, 2, 3, etc. to correspond to your HALion outs

Thanks for the replies. I’ve tried both of those mentioned. I also got a reply from Steinberg youtube that I have to press F11 and open it as an instrument rack which I don’t remember doing on the other songs I recorded. I will try it tonight but so far none of the other drop down Sounds only the first one plays regardless of what track I select in the recording screen.