Halion Sonic SE2 settin presets

HI everybody,
I created a project importing a MIDI file and routing MIDI tracks to Halion Sonic SE2 sounds, selected in vst instrument rack, but when I reopen the project sounds are wrong…
I can’t select sounds from inspector…
I’m I missing some passage?
Thank you,
arfo
Halion presets.png

Hi,

  1. What about your MIDI File Import settings? Do you use multi-ti bral HALion Sonic SE2, or Instrument Tracks?

  2. Do you save the project as a CPR, or do you export it as a MIDI File?

Hi Martin,
thank you for answering!

\

  1. What about your MIDI File Import settings? Do you use multi-ti bral HALion Sonic SE2, or Instrument Tracks?

you can see them in the attached image

  1. Do you save the project as a CPR, or do you export it as a MIDI File?[/quote]

I save as a cpr…
midifile import options.png

Hi,

Does the sound change, in a meaner of completely different sound (preset)? Or is it “the same sound” with changed parameters?

wrong preset.png
right preset.png
wrong preset.png
Hi Martin,
as you can see in the attached pictures the sound type doesn’t change but the specific preset is not the right one…
I partially solved the issue saving a preset in HAlion but I can’t eliminate the wrong preset setting in the
inspector…
saved preset.png

last image…
inspector wrong sound.png

OK, it’s obvious, HALion Sonic switches to the GM Mode. Do you send a SysEx message to do so?

HI Martin,
sorry for my late…
I create the original midifile in Sibelius with GM sound set but, after importing it in Cubase, I generally cancel every CC in List editor, so it shouldn’t be a problem…
Maybe, I guess it now, importing itself makes Cubase having the GM instrument names in the inspector, resetting Halion settings every time I restart the project…

Hi,

GM On event is a SysEx message.

So I have to change something in Sibelius settings before exporting, right?
Many thanks :slight_smile:

Or delete the SysEx message in Cubase, if there is any.

Hi Martin,
I solved the issue deselecting the general midi option in Halion…
When I reload the project all sounds are ok now!
Thank you for helpin’ me! :slight_smile:

Hi,

Yes, this is the option. I was thinking, it’s triggered by the SysEx message, but it was probably your General settings.

I’m glad it works, now.