HALion Sonic SE3 Missing Instruments

Hi clever problem-solving types, I wonder if any of you can help me.

I upgraded from Studio 4 to Artist 10.5 recently. Everything works except HALion. Some instruments will load, but most won’t. I get a message saying “Some audio files are missing, please check installation.”

So far I have tried uninstalling a reinstalling Both HALion and Cubase. I have downloaded HALion separately and installed it that way instead (no instruments at all that way, nor even lists of instruments that won’t load).

I have been using the library manager to move the libraries from my tiny C drive to my big D drive, but I also tried using HALion before moving the libraries, but same problem, so it doesn’t look like the fault occurs in the move. Also tried installing Cubase on D.

Any ideas?

I have started a support ticket, but no reply for 20 days so far, I think because they are being severely disrupted by the pandemic.

Anyone have any suggestions?

You should list all of your computer details. This will give everyone help in what is best to do.

No problem:

Dell Inspiron 5770
Windows 10 Home 64-bit version 1909
Intel® Core ™ i7-8550U CPU @ 1.80GHz 1.99
8.00 GB RAM

I recently installed a copy of Cubase LE on my office PC which includes the same version of HALion. I get the same error whenever I start it up. Mostly been ignoring it because the installation is only to capture ideas & anything of value would happen on my main DAW. Still it is annoying to get the error, and click OK. Reinstalling didn’t help either. It doesn’t indicate what content is missing, just that some is.

I finally solved the problem. I’ll explain how in case it is useful to someone else.

The original download zip when I upgraded was 20.0 GB but yesterday I noticed that unzipped it was only 11.6 GB. I don’t know if the zip file was corrupted or something when wrong during the unzipping.

So I downloaded Artist again but using the Steinberg download assistant. The zip was also 20.0 GB, but this time unzipped to 25.1 GB. I ran the installer from that using the “reinstall” options.

I started up Cubase, but still had a problem with HALion SE - it said there was no “Flux” and the instrument edit button for it in Cubase was greyed out so I couldn’t access HALion at all. I went to the installer again and ran the “update” option for HALion, and this time it worked.

Running out of space on my C drive may also have been an issue I moved some things before I attempted the reinstallation.

If I could suggest an improvement for the future, it would be to allow people to choose the drive that the libraries are installed to during the initial installation. This would solve the problem of limited disc space, given that so many people now have computers with a small SSD C-drive and a big HDD D-drive.