HALion Sonic sounds cause crashes, do not load correctly

Most times when I attempt to select HALion Sonic as a VST instrument, it returns this error.
image
Other times I will get this error upon returning to Dorico after a while with these sounds loaded, then the app will hang and I will have to close it and restart the VST engine. Is there a way to fix this?

Hi @ryanevangelho ,

I’ve never seen that error message before, very odd one. I guess I need to get in contact with our HALion team, but first , please choose from Dorico’s menu Help > Create Diagnostic Report and attach the corresponding zip file to a reply here. I want to see if there are dump files. Those are essential for deeper analysis.
Thanks

Thanks for the data.
Unfortunately the logs don’t give me any hint on what is going on there with you. Therefore I need to get in touch with the HALion Team, but since we are now in a long weekend (Monday is also a public holiday here), you need to be a little patient.
But one more thing, there are 5 or 6 crash dumps of the audio engine contained in your data. They all show the same stack pattern, and it is a weird one I’ve never seen before.
When you get that mentioned error message and don’t prompt the OK button, when you then invoke TaskManager and have a look for a process called VSTAudioEngine5, how is the status, not responding? Is it still around.
I’d even like you to download the free utility Process Explorer because it is more reliable and powerful than TaskManager. So please run that procexp64.exe and look for ‘VSTAudioEngine5.exe’. You can filter the list of processes. At the right top of the Process Explorer is a filter where it says . If you type in just VST you should only see one VSTAudioEngine5.exe.