Halve note duration (again) (bug? used to work as expected in 3.5)

I’m obviously not getting how this is supposed to work, but I’m trying to use Halve Note Duration to get from here:

Screen Shot 2022-01-19 at 2.30.10 PM

to here:

Screen Shot 2022-01-19 at 2.30.46 PM

but with Insert on, I get this:

Screen Shot 2022-01-19 at 2.31.50 PM

and with Insert off, I get this:

Screen Shot 2022-01-19 at 2.32.40 PM

Is this as expected? How do I get what I think I’m going to get? Thanks!

Before you half the duration, invoke insert mode (shortcut i)

Thanks, but that gets me the result in the third image.

Oops, sorry I misread the thread. I think the transformations just include note values, I am not aware that tests are affected by it. (Maybe explicit rests)?

Anyhow, press alt-left arrow with an 8th note grid afterwards.

(On a side note, I couldn’t see how to change that rest duration to half. Selecting it and clicking on the eighth note didn’t work.)

Hi, did you mean shift-opt-left arrow? That gets me to the same result as the last image.

It looks like I’m already on 8th note grid …?

Screen Shot 2022-01-19 at 2.41.31 PM

No, from the third image ongoing, select the eighths and press opt-left arrow

1 Like

Ah, got it. So it looks like Halve does not work on the rest; I have to move the notes to the left to shorten the rest.

Thanks! I wonder is that a bug or a feature :face_with_raised_eyebrow:

Not sure if it’s new in Dorico 4 but you can use cmd+alt+shift + left/right arrow to half/double the values. With Insert on in this case.


1 Like

Thanks, that shortens the notes only, and I have to then move them to the left.

But is there a way to shorten the rest without moving the notes?

I have just tried this in 3.5 and 4, and there seems to have been a change. In 3.5 I get the expected eighth rest; in 4 it remains a quarter rest while the notes change.


But it that progress? :stuck_out_tongue_winking_eye:

Try this:

Select the whole bar

Press “O” (Force note duration)

Press “I” (Insert)

press “5” (eighth-note)
Select Write > Edit Duration > Halve Note Duration
Adjust the slur

1 Like

The function you are using is called „Halve Note Duration“. Rests are no notes.

I think there is a small bug here. I think something is up with the way that duration edits are working on rests in Insert mode. I think it’s specific to rests that come at the start or the end of the selected region. We’ll investigate.


Thanks! But was hoping for an easier way to do this. Looks like there may be a bug.

Lol good point

Weird. Is that on Dorico 4? I get this:

Screen Shot 2022-01-20 at 9.41.08 AM

So do I, unless I apply Force Duration as well as Insert after choosing the measure and pressing 5 for eighth notes (or Halve Note Duration) .

Yeah, I don’t think we should have to “use the Force” lol

Looks like they flagged it as a possible bug.