Hard Panned Tracks Audible on Opposite Sides

Sorry if this is an old issue, but I can’t find a fix for this ANYWHERE, and older threads on this topic haven’t given me a solution.
So here we go (again, for some of you).
When I hard-pan tracks, I can still hear them faintly in the opposite side. This is an issue because I create backing tracks for my bands, and I have a click hard-panned left, and the other tracks hard-panned right so they can be separated to monitor and mains/FOH. The bleed means that the audience can faintly hear the click during the count-in, and when the other tracks are quiet.
Before anyone tries to tell me “have you tried…” let me tell you more.
-It makes NO difference whether I go through my laptop’s “generic” driver and out of the headphone jack, or through my USB interface (a Scarlett 18i20). In either case, I get the bleed.
-Recording tracks strictly through one mono input bus doesn’t help.
-Removing the plug-in reverb doesn’t help.
-Changing pan law settings doesn’t help.
-When the click channel is muted, there is no bleed; same with the other tracks on the right.
-I’ve also tried to do separate audio mix-downs of the left-side click and all the right-side tracks. Each of those individual mixed-down tracks is clean, but when you play them together, they bleed. It happens no matter what is selected in the “Audio Engine Output” section.
I’ve tried other things, so I’m sure I’ll remember them if you suggest them. It seems to be an issue with playback in Cubase but the manual hasn’t shed any light on this.

Bump - please, I need help!